Octoprint won't recognize log in

#1

What is the problem?
I'm still new to this but have been printing successfully for a couple of months. Have Octoprint and Printoid set up and this setup has been working perfectly.
Went to print today after a few days off and Octoprint will not recognize my log in. Error message - Login failed User unknown or wrong password. No changes have been made to my user name or password.
I can see my files, monitor my camera and see the Terminal. I can also operate using Printoid and see the operational state make the changes in Octoprint. No problem making a connection.
Any thoughts on why I can no longer log in to Octoprint?

What did you already try to solve it?
Tried logging in from several different computers and browsers. Restarted Pi and computer and retried.
Retried entering in the log in information even though it was saved and had always worked properly in the past.

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)
OctoPrint 1.3.8 running on OctoPi 0.15.0
Using a Creality CR10
FIRMWARE_NAME:Marlin V1

#2

Is there anything interesting in octoprint.log? You should also look at .octoprint/users.yaml to see if perhaps you hand-edited it and corrupted it or something.

In any case, here's how to fix:

#3

Perfect!
Works now but still not sure how my password was corrupted.
Thank you for the help.

#4

Hi just followed instructions so still cant log in and Octoprint isnt running setup . what can I do next

#5

There aren't many steps necessary in that linked set of instructions but you have to follow each step to include the part where you reload the page. And by "reload the page" this might mean "reload the page dammit", as in "hard reload" or "clear your browser's cache and reload" or "delete the cookie associated with OctoPrint and reload".

The simple version might be to use a different browser if you have a second one installed.

#6

I cleared cache and all History etc. The strange thing is i was until i did this able to see the printer but it would not give the setup screen so I could set new User/Password

#7

Even tried edge instead of Chrome no joy

#8

And you did this?

# From remote PuTTY session to Raspi...
rm ~/.octoprint/users.yaml
nano  ~/.octoprint/config.yaml
# search for `firstRun: false`, replace with `firstRun: true`, Ctl-o, Ctl-x
sudo reboot
# quit your browser(s) using Alt-F4
# when the Raspi starts again, visit with browser
#9

No this
If you are running OctoPi , you can use these commands to do all that:

rm ~/.octoprint/users.yaml
sed -i -e 's/firstRun: false/firstRun: true/g' ~/.octoprint/config.yaml
sudo service octoprint restart

From the Password reset above I shall try yours if that is correct

Follwed your post and it then run setup and I am in thru browser :slight_smile: I will now try thru cura and see how that goes Success so far thanks. ---- Had to edit as new user and not allowed more posts

#10

It should be the same if the second one was done perfectly. Just verify that the variable is toggled in the config file; that's what triggers the Setup Wizard.

Note that if your original config.yaml had two spaces, for example between the firstRun and the false for some reason, then it wouldn't work as expected.