Octoprint won't start, log file empty

The problem:
During some plugin updates, OctoPrint got stuck in the 'updating' window (in the GUI).
After waiting for a long time (>1h), I've decided to reboot it, by giving the command 'Sudo reboot now' over SSH. The reboot began immediately.

Unfortunately, OctoPrint won't start now, giving the well-known info-page (when going to the GUI) saying:

The OctoPrint server is currently not running
If you just started up your Raspberry Pi, please wait a....... etc.

SSH is still possible by the way.

What I've tried already:
Now, I've tried looking in the logs, but didn't seem to find any usefull information.
As of the comments over here tell, I also 'deleted' the log and did a reboot, so it would come up with a nice and fresh log file, pointing out the issues. Too good to be true, this didn't happen, no log file is created whatsoever it seems. See:

pi@octopi:~ $ more ~/.octoprint/logs/octoprint.log
more: stat of /home/pi/.octoprint/logs/octoprint.log failed: No such file or dir ectory

Luckily I've saved the 'old' log file, you can find it below.

I'd like to have it back up and running, preferably with keeping all my plugins in place.
If there's any way to re-install OctoPrint without loosing my plugins, that also seems like a good option to me, but I'm not yet aware of a way to achieve this.

Thanks for all your help in advance!

Extra info:
Octoprint is running on Pi 3b (+?)

First I would try if it starts in safemode :slight_smile:

Thanks! Immediately tried it, this is what the SSH session tells us:

pi@octopi:~ $ ~/oprint/bin/octoprint safemode
ERROR:octoprint.settings:Could not write test file to /home/pi/.octoprint/logs
Traceback (most recent call last):
  File "/home/pi/oprint/local/lib/python2.7/site-packages/octoprint/settings.py", line 1850, in _va                                                                                                      lidate_folder
IOError: [Errno 28] No space left on device
Traceback (most recent call last):
  File "/home/pi/oprint/bin/octoprint", line 11, in <module>
    load_entry_point('OctoPrint==1.3.11', 'console_scripts', 'octoprint')()
  File "/home/pi/oprint/local/lib/python2.7/site-packages/octoprint/__init__.py", line 609, in main
    octo(args=args, prog_name="octoprint", auto_envvar_prefix="OCTOPRINT")
  File "/home/pi/oprint/local/lib/python2.7/site-packages/click/core.py", line 764, in __call__
    return self.main(*args, **kwargs)
  File "/home/pi/oprint/local/lib/python2.7/site-packages/click/core.py", line 717, in main
    rv = self.invoke(ctx)
  File "/home/pi/oprint/local/lib/python2.7/site-packages/click/core.py", line 1137, in invoke
    return _process_result(sub_ctx.command.invoke(sub_ctx))
  File "/home/pi/oprint/local/lib/python2.7/site-packages/click/core.py", line 956, in invoke
    return ctx.invoke(self.callback, **ctx.params)
  File "/home/pi/oprint/local/lib/python2.7/site-packages/click/core.py", line 555, in invoke
    return callback(*args, **kwargs)
  File "/home/pi/oprint/local/lib/python2.7/site-packages/click/decorators.py", line 17, in new_fun                                                                                                      c
    return f(get_current_context(), *args, **kwargs)
  File "/home/pi/oprint/local/lib/python2.7/site-packages/octoprint/cli/server.py", line 165, in en                                                                                                      able_safemode
    settings = init_settings(get_ctx_obj_option(ctx, "basedir", None), get_ctx_obj_option(ctx, "con                                                                                                      figfile", None))
  File "/home/pi/oprint/local/lib/python2.7/site-packages/octoprint/__init__.py", line 171, in init                                                                                                      _settings
    return settings(init=True, basedir=basedir, configfile=configfile)
  File "/home/pi/oprint/local/lib/python2.7/site-packages/octoprint/settings.py", line 81, in setti                                                                                                      ngs
    _instance = Settings(configfile=configfile, basedir=basedir)
  File "/home/pi/oprint/local/lib/python2.7/site-packages/octoprint/settings.py", line 645, in __in                                                                                                      it__
    self.sanity_check_folders(folders=["logs", ])
  File "/home/pi/oprint/local/lib/python2.7/site-packages/octoprint/settings.py", line 665, in sani                                                                                                      ty_check_folders
    self.getBaseFolder(folder, check_writable=True, deep_check_writable=True, log_error=True)
  File "/home/pi/oprint/local/lib/python2.7/site-packages/octoprint/settings.py", line 1569, in get                                                                                                      BaseFolder
    _validate_folder(folder, create=create, check_writable=check_writable, deep_check_writable=deep                                                                                                      _check_writable, log_error=log_error)
  File "/home/pi/oprint/local/lib/python2.7/site-packages/octoprint/settings.py", line 1855, in _va                                                                                                      lidate_folder
    raise IOError(error)
IOError: Folder at /home/pi/.octoprint/logs doesn't appear to be writable, please fix its permissio                                                                                                      ns
pi@octopi:~ $

Is it possible that your sd card is full?
Try df -h

1 Like

I think you're right!
I suspect the problems with creating the timelapses to have eaten the storagespace. Is there any way to confirm and repair this?

pi@octopi:~ $ df -h
Filesystem      Size  Used Avail Use% Mounted on
/dev/root       7.1G  6.8G     0 100% /
devtmpfs        434M     0  434M   0% /dev
tmpfs           438M     0  438M   0% /dev/shm
tmpfs           438M   12M  427M   3% /run
tmpfs           5.0M     0  5.0M   0% /run/lock
tmpfs           438M     0  438M   0% /sys/fs/cgroup
/dev/mmcblk0p1   44M   23M   22M  51% /boot
tmpfs            88M     0   88M   0% /run/user/1000

Additional information:

pi@octopi:~ $ sudo du -xh / | grep -P "G\t"
1.8G    /home/pi/.octoprint/timelapse/tmp
4.0G    /home/pi/.octoprint/timelapse
5.0G    /home/pi/.octoprint
5.2G    /home/pi
5.2G    /home
6.8G    /

Well I think 0 available space is pretty confirmatory :smiley:

I would suggest you move the timelapse videos to your pc and delete the old timelapse temp images (I guess it run out of space during the last tamelapse) :slight_smile:

If you're on windows one easy way would be to use WinSCP :slight_smile:

Don't forget to restart the pi after you have free space again :wink:

If the partition ran out of space, it's a good idea to also do an fsck on it to clean it up.