Octoprint won't start since 1.5.0, Segmentation Fault

What is the problem?

"The OctoPrint server is currently not running". I went today to try to start a print and encountered this error.

What did you already try to solve it?

Reboot over SSH. No dice.
apt-get update and upgrade. Nothing.
Restart service. Still nothing.
Verify the process is running (ps -ef | grep -i octoprint | grep -i python). Returns nothing.
Check the log. Nothing appears to have caused an error.

Have you tried running in safe mode and if so did it solve the issue?

I tried "~/oprint/bin/octoprint safemode". Terminal returns "Segmentation Fault". Is this an issue with my SD card? I'd prefer not to reflash but I can if that's the solution.

Complete Logs

Here's my log. Serial.log wasn't enabled apparently and only has a few lines saying as much.
octoprint.log (12.5 KB)
The only thing I see when trying to reach it.

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

OctoPi 0.17.0
OctoPrint 1.5.0
Using w/ Ender 3 Pro, SKR mini E3 V2, Marlin

Segmentation fault suggests something pretty wrong with the underlying OS/Python installation. I'm not aware of a way to save it, flashing the SD card might be the best option.

1 Like