OctoPrint won't stop my print with a pause

Using the PrusaSlicer I discovered that we are able to insert a pause in mid print.

I wanted to use such feature to insert a lens in my print so I don't have to glue 2 parts to make my magnifying glass.

But unfortunately the print didn't stop at the specified layer. Trying to manually pause the printer from the LCD didn't worked either.

The only way to stop my print is to print from the SD card instead of using OctoPrint.

Is there a pre-requisite to be able to trigger a pause from the G-code using OctoPrint?

Apparently PrusaSlicer insert an M601 command, maybe this had to be somewhat changed to another G-code command?

My 3D printer is an Ender 3 with an alternative 32-bit board : BIGTREETECH-SKR-mini-E3 V1.2

I'm using the stock firmware : firmware-bltouch-for-z-homing.bin

I tried to look into the Configuration.h to see if there was a pause feature to enable but I didn't see it.

I've tried to pause, it didn't even trigger automatically when printing from the SD card... Maybe I need to tell the slicer to issue another G-code that is not M601 ...

Hello @Asher541

Try it with inserting @pause at that certain line in the gcode file.


To add, when you right click this little + in PS, you can add the custom gcode:

The M601 command is sent to the printer, it is up to the printer to then tell OctoPrint to pause the print. The @pause command is sent to OctoPrint, not the printer so it successfully pauses the print. You can also add M601 to the 'Pausing commands' section in OctoPrint's serial connection settings, so it will pause the print when it sees that command being sent as well.