Octoprint worked great, but now stopped working

Hello everyone, I‘m somewhat new to octoprint.

Short description:
4 day ago I set up octoprint via the octopi bundle thing on a Raspberry pi 2B on my balcony.
It worked absolutely flawless. Then I dismanteled my setup and put everything inside because of low temperatures.
Now I’m trying to get it to work and failing for two days. I have tried everything I could think of…

long description:

  • put Ender 3 Pro on balcony
  • Installed octopi(newest version I could find) on Raspberry Pi 2B without Problems, (Pi connects with W-lan dongle, no camera)
  • Power: 2,4A 5V Anker phone charger. (I don’t have a dedicated 5V Suply)(tried dedicated PSU now)
  • changed Octoprint password in Browser.
  • set a fixed IP in my Router for Octopi (
  • Installed Plugins:
    octo print time genius
    Exclude Region
    PSU control
  • connected a relay to Printer power cord. (relay controled via: 5v, GND, GPIO 14)
  • activated Setting to send Gcoded direct from PrucaSlic3er 2.2.0 to Octoprint.

Everything till now worked flawless. (I can turn the printer remotely on and off, the web GUI is responsive and fast. I click in Pricaslicer and the Printer starts printing without octoprint GUI interaction)

gray low Voltage symbol showed up in Octoprint

  • I don’t know If that is really low voltage because when I click it, the description says that a red low voltage symbol is low voltage and mine is grey and not red?? (vanishes with dedicated PSU, doesn't solve problem)
  • When the printer is turned off, the printer screen in powered via the pi usb. Everything worked still.

I disassembled everything, and reassembled the next day. And it absolutely refuses to work…

  • Octoprint needs an hour to load in the browser(firefox) via octoprint.local or its IP, and never loads fully at first.
  • Now it always times out after 5s. (Linux, Win10, Android the same)
  • Octopi sometimes connects to my router, than its gone, than its here again, than its gone…

Tried solutions:

  • disconnected everything, except wlan.
  • put pi next to wlan
  • used other phone charger
  • used other cable
  • installed new octopi on new sd card.
  • EDIT: powered pi via 5V 14A PSU (browser GUI loads now partially in 30min, but not fully)
  • EDIT2: connected pi via Ethernet. browser GUI works very well -> Problem is wlan related

Nothing I can think of works, please help

octoprint_logs.zip (38.8 KB) octopi_logs.zip (72.6 KB) octoprint.log (4.2 KB) serial.log (148 Bytes)

You appear to be contradicting yourself. And yes, how you're powering it is a problem.

A charger is a charger and a power adapter is a power adapter. They're two different things. Get the bonafide 5V @ 2.5V Raspberry Pi power adapter. Since you're ordering things, it wouldn't hurt to order a Raspberry Pi 3B at the same time.

thanks for the Answer,

when the pi worked perfect, I powered it via a Phone charger and it worked fine.
I suspected the phone charger too, therefore I tried it with a computer power supply 5V 14A.
(edit: I have now clarified this in my first post)

Now Octopi.local loaded half of the GUI in 30min, so that was “somewhat better” but it still is not functioning.

That’s why I said it is not the Power supply. At least not the main culprit I think. There is a(nother) Problem elsewhere...


ps: yesterday I ordered this power suply https://www.amazon.de/gp/product/B01DDFFOYK/

That should work just fine.

A charger produces pulsating DC. If you saw this on an oscilloscope you'd see postive-going camel humps rather than a straight line. It's just not what the Pi needs, causing problems.

The big computer variety of power supply has power leads that need to be seen on the Pi. So you might think that you're giving it 14A but the reality is that the tiny wires and pins of the Pi can't accommodate that. The technical rating for a microUSB connection's power is less than the 2.5A that it requires, to be honest.

I understand that many people have problems with unsuitable power supplies and you are trying to help and I'm grateful.
But I have a background in electronics, so please, let’s omit the discussion about power supplies.

Anyway, I pulled out the wlan dongle and connected the Pi via Ethernet, and now the browser octoprint GUI works and is as fast as I remember it.
So I’m guessing the Problem is the wlan connection or the pi talking to my wireless access point. What I don't understand is, it worked before and I changed nothing.

Sadly I need to use wlan. Ethernet is not available where I want to put my printer.

:laugh: This is what I meant by that.

Sounds like your filesystem on the SD card is corrupted if it's taking that long. When you power off the pi, do you use either shutdown -h now via ssh, or use the power off system in the octoprint web gui? Or do you just kill power?

Ok, if you put the WiFi adapter in AFTER installing octoprint, there are no hooks or bindings in the network configuration and installation of haproxy for the WLAN0 interface. Put the Wifi adapter back in, then reinstall octoprint.

So it seems to be fixed.

What I did was to delete the fixed IP for octopi in my router and restart the router.
Than I could access Octoprint via browser. So I put the PI on the balcony next to the printer. And could not reach the web interface again.
So I put the Pi back next to the wlan switch, tried again, could reach octoprint. Back on the balcony and now I can reach octoprint reliably again.
How a fixed IP for the OctoPis MAC address seemed to be the Problem, I don’t understand...

Is that normal??

@5ft24 When I could reach Octoprint I always powered down, but when I could not reach it with octoprint I needed to pull the plug (unreachable trough ssh either)

@rcw88 I Installed Octopi with the wlan adapter. I just took out the wlan adapter to check if the Pi was reachable per Ethernet.

Well thanks for the help, it seemed the Problem was somewhere with the PI not properly talking to the Router or something.

1 Like

I find that the drivers related to the dongle style of Wi-Fi adapters were poorly written in the first place and then weren't updated as newer versions of Raspbian came out.

In other words, when the Raspberry Pi computers came out with embedded Wi-Fi network adapters then almost nobody wanted to waste a USB connector for a dongle. People stopped buying/using them for this, driver maintenance didn't happen at the frequency required to make them work well. The embedded Wi-Fi adapter uses less power than the dongle version. I'm not entirely convinced that the dongle-based drivers have the Energystar power-saving features turned off now.

The combined cost of a Pi + dongle is usually more than just a new Pi 3B.