Octoprint Z offset too high and will not go any lower through control

What is the problem?

Cr10s Pro V2 - Offset and leveling set up on printer. If I use the sd card I get near perfect prints without level or z offset issues. Once I take the Gcode to Octoprint the nozzle is either way too high or too low. This has created issues with my nozzle digging into the bed or wasting filament.

What did you already try to solve it?

I have attempted to pause multiple prints and adjust the z offset using the controls in Octoprint. If the nozzle is too high, it will not let me go any lower using this controls. The axis stops lowering past a certain point for the z axis. (if i do this manually on the printer it works until I resume on Octoprint and then it raises again). I have had to manually adjust the offset at the rails to get anything close to a decent print when using Octoprint.

Have you tried running in safe mode and if so did it solve the issue?

Yes, it did not solve the issue. I have minimal Plugins (Octolapse, spaghetti detective) because this is a brand new canakit setup and I didnt want to complicate anything.

Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)

NO logs available - all prints have been cancelled.

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

OCtoprint version Version 1.4.2, Raspberry Pi 4b, Cr10s Pro V2 - stock firmware, microsoft edge, windows

Why? Logs are good.

We might also need the serial.log to see if this is a firmware issue (eg, OctoPrint is sending the right things, but the wrong thing happens)


Might be the soft endstop
yo can disable it for setting an offset that works for you and enable it again when you're done

octoprint.log (146.1 KB)

Hello Charlie,

Ive added a log here. Please let me know if this helps. I am very new to all of this especially Octoprint.

please also add a serial.log
just start a small print and cancel it after the first layer
so we can see what's going on

Where do I enter the commands to disable the endstops?

in the terminal

but just to be sure - you have to home your printer before you can set an Z offset

Ok, ill be right back with the serial. log

I tried to do another print and the z axis just went to the top of the gantry and was trying to grind itself to infinilty. I really dont understand why this doesnt work. I have included a serial log from another print I did unsuccessfully with Octoprint. serial.log (296 Bytes)

2020-11-12 20:43:33,498 - serial.log is currently not enabled, you can enable it via Settings > Serial Connection > Log communication to serial.log

You have to enable the serial log to get a real one.

The controls in OctoPrint move the nozzle using ordinary G0/1 commands, this has no effect on the z offset. If you use these controls while paused in the middle of a print job, the nozzle will return to its original position once the print is resumed.

To duplicate the z offset control on the printer itself, you need to use M206 commands. Also available is the M851 command. The z offset may be stored in the EEPROM so use M500 to store an updated value (see M501-M503 as well)

I don't own a Creality printer so I don't know how they implemented printing from the SD card with regards to homing, leveling, and setting the z offset. If you create a small object like a 2x2x2mm cube, slice it, print it from the SD card successfully, and then upload that gcode here, it will help us understand the issue better.