Octopy and printer shut dow after connection

What is the problem?

Since the last update of octoprint, it is not possible to connect the printer with Octopi.
Printer and Octopi starts proper. Also the printer and Octopi will be connected. After half a second the message on the Octopy appears "M600 Hodend too cold to change filament" and on the Printer appears "Printer error, please reset"

What did you already try to solve it?

  1. I thougt it is a problem with the Update and installed Octopi on a new card with the Raspberry Pi manager (Octopi image 0.18.0 with Octoprint 1.8.6) --> no improvement.
  2. I checked connection between printer and Laptop via Simplify 3D --> can connect and move axis.
  3. I tryed to print from SD Card --> that works.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)
octoprint-systeminfo-20221211104826.zip (68.8 KB)

I hope I did it right!

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

my printer is a "old" Anycubic 4Max with Marlin 2.0.7

Hello @Peter72 !

Please do so.

Also try this plugin:

And note this:

2022-12-10 14:54:02,705 - octoprint.util.comm - WARNING - Received an error from the printer's firmware: M600 Hotend too cold to change filament
| Last lines in terminal:
| Recv: Cap:PROGRESS:0
| Recv: Cap:PRINT_JOB:1
| Recv: Cap:AUTOLEVEL:0
| Recv: Cap:Z_PROBE:0
| Recv: ok
| Send: M21
| Recv: echo:SD init fail
| Recv: ok
| Send: M105
| Recv: ok T:13.44 /0.00 B:15.43 /0.00 @:0 B@:0
| Send: M155 S2
| Recv: ok
| Recv: echo:enqueueing "M600"
| Recv: Error:M600 Hotend too cold to change filament

There a lot of errors cause by the telegram plugin. Try without that one.

Hi Ewald,
thank you for your fast response.

First I installed the Plugin you recomended and started Octopring again. --> same Error
Than I deinstalled the Telegram Plugin, started Octoprint --> same Error
Than started octoprint in safe mode --> same Error

Than I connected the printer ons again to Simplify. There I saw that this error is as an Echo in the communicaton window.
Now I saw that there is no filament in the filament sensor. so I put in a small pice of filament for a test.
The error disappeard and octoprint worls poperly!

To be honest, I do not understand way this Error appears in the Firmware, but o.k. now it works.

Thank you so much for your help!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.