OctoScreen - a new software to use OctoPrint with LCD

Yes the fbcp is installed by default by the Adafruit installer. It might not be installed by software for other displays, I didn't realise that. It's going to be slightly different for different brands anyway.

Hi everyone, I wanted to ask how octoscreen is installed. I'm trying in every way but nothing, black screen.
I have a Kuman 3.5 display and raspberry pi3B +, thanks

There is a github link in the first post...

done, I managed to install it and see correctly on the LCD but I have to install it again and I can't do it anymore. there is no tutorial?

I have problem with installation.
Im using Raspberry 3b+ and Raspberry 7" touchscreen display.
Try installation guide from github for .deb installation but without success.

When I get to this step: sudo dpkg -i octoscreen_2.3-5_armhf.deb
It respond with this: Failed to preset unit:
File /etc/systemd/system/display-manager.service already exists and is a symlink to /lib/systemd/system/lightdm.service.
/usr/bin/deb-systemd-helper:
error: systemctl preset failed on octoscreen.service: No such file or directory

And this is end of the way for me, please can someone help me with this instalation.
Thank you in advance.

I'm just guessing and haven't tried octoscreen yet but is the raspbian desktop or something similar already installed?

Hi folks!
I managed to install octoscreen on original 7 inch LCD and works fine UNTIL i open network tab - then resolution extends a bit on the right side. It's all fine until i open network tab, after that resolution on all tabs is somewhat wider, like something is changing resolution from correct 800x480 to around 800x500, so a small part of screen on the right side can't be shown, of course...

Any clues? My resolution is set to 800x480, same as original 7 inch LCD.

Thanks!

You might want to open up an issue to the plugin author's repository.

OK, i guess i'll just do that. Many thanks!
I also found out that "unload" doesn't work on my Prusa, while "load" does work. Since i have autoload i would like exactly reversed...

I had this same issue. I used "sudo dpkg -r --force-depends lightdm" then installed the octoscreen deb file. Hope this helps.

Anyone know if its possible to take screenshots of the ui?

If it has the x windows system running then I'm guessing that VNC would then work as well. (You'd install that from sudo raspi-config for what it's worth.)

Then, from a remote session from your workstation, you could do a standard screencapture to get the content.

On macOS, though, you need to tweak the VNC server configuration so that it's backward-compatible on the authentication.

Rob, doesn't work for me, system says i don't have lightdm installed.

And you saw this, right?

Yes, i tried that command and i get a reply like " ignoring command to remove lightdm since its not installed".

You might want to create an issue on the plugin author's repository to let them know.

Does it also work with a composite screen?

I'm guessing that it requires a TFT.

Hi,

Thanks to all the great support in this thread already I now have OctoScreen installed and the screen resolution fixed. I still have a problem though... My OctoScreen instance keeps switching between the main screen and then back to the original pi login command line - it switches between the two every 10 seconds or so.

I've tried looking at auto-login options to see if that helped but when I added a AutologinAs to the config.yaml it stopped Octoscreen working altogether. :frowning:

Any ideas?

Thanks.

First things first, you should try to get your config.yaml back to where it was before. The formatting is particular, especially in the beginning whitespace.

Once you get that working again then you might open an issue on the plugin author's repository to see what they have to say about the problem you're seeing.

1 Like