Octoscreen does not fully install - no service installed

What is the problem?

I have OctoPrint working on a pi4, but when I install octoscreen using dpkg command per github it does not install the service, even though no errors are generated.

What did you already try to solve it?

reinstalled multipel times, manually edited config, turned on logging, added service to rc.local, etc. but since there is no service, nothing gets logged.

Have you tried running in safe mode?


Did running in safe mode solve the problem?

octoprint-systeminfo-20240407173844.zip (62.3 KB)

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

PI4 running octopi. al fresh and upgreded software as of today.

I think I figured it out - I didn't have a user named "pi" in my system, so no /home/pi folder, where octoscreen stores everything, I believe.
I re-ran the pi imager and made the user name pi instead of dave, and everything just worked.