Octoscreen plugin doesn't launch to UI

Dumb question - When I install the Octoscreen plugin via URL in the plugin manager, it installs OK. But, the PI doesn't boot into it... I feel like I'm missing something simple... any help?

Hello @MPFG !

Where have you found that. It's not in the OctoPrint Repository.

There is a product called OctoScreen that supports an extarnal touch LCD. But that one is not installed via the plugin manager.

There is an associated plugin to that, which I assume is to allow it to pull some of the needed data for display in the main application that you linked, which would need to be installed separately.

1 Like

Hi Ewald - thanks for replying. There appear to be two ways to install Octoscreen. One is via the link you provided, and the other is actually provided in the response after yours. In January I installed Octoscreen via the method you provided. Everything went smoothly. I had to reinstall, and now it has lost dependencies somehow and won't complete install. I posted about it on GitHub here:

My second raspberry pi also has the same issue when trying to install - so this is the currently the path of most resistance. If you have insight, please let me know. At the same time, I found the second method, which is installing it via plugin manager. You can install plugins by both finding them, or plugging in a URL to a plugin elsewhere to be installed. I can get that to install perfectly, but when I reboot... nothing happens. It should load directly into Octoscreen but doesn't. So I'm hoping that troubleshooting THAT issue is a lot easier...

1 Like

Hi jneiliii - The link you provided is exactly what I installed. Throw the .zip URL shown on that page into the plugin manager, and away it goes. Seems to install perfectly. There are no further instructions though... nothing else mentioned to be installed separately... where would it be?

Yeah, the plugin alone is not enough for OctoScreen to work. Your posted issue is probably related to Raspberry Pi Foundation doing stupid stuff and converting 32bit user space to 64bit during sudo apt update operations. We had a similar issue going on in the OctoDash group. I assume you did run the prerequisite commands for the dependencies? I see from your attachment in that issue that you did.

sudo apt-get install libgtk-3-0 xserver-xorg xinit x11-xserver-utils

Hi jneilii - I think there is a gap here I didn't try. The issues I posted on GitHub was a different way I installed it. I installed the dependencies in this case. When I went via the way you posted (.zip / plugin manager), I didn't do this before hand. Maybe if I install the dependencies and then try the plugin manager it will work... but then again, installing the dependencies is where I ran into issues. Cross your fingers.

I think you are still confused - the app to display on a touchscreen can't be installed from within OctoPrint's plugin manager and it's not a plugin. It must be installed separately, this is what you are having trouble installing.

There is then also a 'companion plugin' that goes along with OctoScreen to enable extra features. This plugin alone is not the touchscreen app.

There's not two ways to install the same thing - there's two different things here.

Hi Charlie - Thanks, that sucks. So no way other than to go the route in Ewald's post above? The past of most resistance?

Ok I got it solved. I reached out to someone on Fiverr - “wrasanga” and here’a what he did:

I downloaded the SD image from the official OctoPi website.
I used BalenaEtcher to flash the SD image to the SD card. (Raspberry Pi Imager sometimes gave me trouble.)
After flashing, I set the Wi-Fi settings using the "wpa_supplicant.conf" file and added the "ssh" file to enable SSH.
Once the Raspberry Pi booted up, I ran the usual commands "sudo apt update" and "sudo apt upgrade" to update and upgrade the system.
At this point, I set up my 3D printer in OctoPi because some recommend setting up the 3D printer before installing OctoScreen.
Then, I installed the necessary dependencies using the following command: "sudo apt-get install libgtk-3-0 xserver-xorg xinit x11-xserver-utils".
After that, I downloaded and installed OctoScreen using the following commands:

wget https://github.com/Z-Bolt/OctoScreen/releases/download/v2.7.4/octoscreen_2.7.4_armhf.deb
sudo dpkg -i octoscreen_2.7.4_armhf.deb
However, I encountered the same error you mentioned, which stated that "octoscreen" depends on "libgdk-pixbuf2.0-0" (version 2.25.2 or higher), but it was not installed.
To fix this, I ran the command "sudo apt-get install --fix-broken" to resolve all the dependency problems.
Once the dependencies were fixed, I ran the command "sudo dpkg -i octoscreen_2.7.4_armhf.deb" again to install OctoScreen.
That's all!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.