Offline after error No more candidates to test, and no working port/baudrate combination detected

What is the problem?
I had a power outage the other day and since then I have received this error:

Offline after error
No more candidates to test, and no working port/baudrate combination detected.

What did you already try to solve it?

I have already tried rebooting the pi, starting it in safe mode, formatting the entire pi and flashing a fresh image, and changing the cable.I can SSH into it, and i can lauch the web browser but I cannot connect to the printer itself once I'm in.

Logs (syslog, dmesg, ... no logs, no support)

I honestly have no idea what logs to check. I'm still very new to octoprint but I have included two logs that looked important.

octoprint.log (21.9 KB)
serial.log (2.0 KB)

Additional information about your network (Hardware you are trying to connect to, hardware you are trying to connect from, router, access point, used operating systems, ...)

I have an Ender 3 Pro with a raspberry pi running of the printers PSU.

did you risk a look into the logs?

serial.log says:

serial.log is currently not enabled, you can enable it via Settings > Serial Connection > Log communication to serial.log

so it's not important as it is.

octoprint.log contains many repetitions of:

 octoprint.util.comm - INFO - Serial detection: Performing autodetection with 0 port/baudrate candidates: 
2021-12-08 03:16:17,033 - octoprint.util.comm - INFO - Changing monitoring state from "Detecting serial connection" to "Error"
2021-12-08 03:16:17,034 - octoprint.util.comm - INFO - Changing monitoring state from "Error" to "Offline after error"

0 port/baudrate combinations doesn't sound good.

In fact, it calls for dmesg and /var/log/syslog

ssh into the box, then
dmesg -w
and, while it's running, unplug/re-plug the serial cable

copy the output into a text file.

tail -n100 /var/log/syslog
and copy it into another text, upload those to this thread.

And, please generate and upload the systeminfo bundle.

@planetar I did look into the logs but unfortunately I'm still learning all of this and me looking into the logs doesn't help much.

I did the dmseg -w and copied that to a text file which can be found below, I'm pretty sure i did it right:
dmeseg -w (9.2 KB)

And I tried to do the tail -n100 /var/log/syslog and have the results here:
tail (2.0 KB)

Ive also included the sys info bundle here: (16.5 KB)

dmesg (that's the kernel talking) reports:

[   18.826542] usb 1-1.5: new full-speed USB device number 4 using dwc_otg
[   18.926486] usb 1-1.5: device descriptor read/64, error -32
[   19.146500] usb 1-1.5: device descriptor read/64, error -32
[   19.366489] usb 1-1.5: new full-speed USB device number 5 using dwc_otg
[   19.466482] usb 1-1.5: device descriptor read/64, error -32

status -32 means "Broken pipe"

Getting the device descriptor is like the first step of usb communication, if that fails nothing goes.

The octoprint FAQ has OctoPrint can't connect to my printer - Docs - OctoPrint Community Forum

@planetar I checked the cable and that isn't the issue. I also have the Pi drawing power from the PSU with a voltage limiter so I don't think that power is the issue either.I will try letting the computer rest and see if that helps any.

@planetar just got back on after letting the computer rest all day and the issue is still unresolved.

Next should be test to find out if the printer's usb and the raspi's usb still work.
to do this you would need a different computer with usb to which you connect the printer. Not to print from there but just to check if that other computer's OS recognizes an usb device.

Similarly, you would need a different usb-device like an usb keyboard or even a mouse to plug into the raspi's usb. Then use dmesg to check if the kernel can get through to that device.

@planetar What do I do if I suspect the USB on the printer to be faulty? I tried to plug in my computer to the printer and it registered that it was plugged in but then gave me a popup that the USB could not be recognized because it malfunctioned.

I'd absolutely start an extended web search on the printer model, usb, motherboard name etc. to try find fellow sufferers and compare their experiences.

A power outage isn't necessarily just a square curve voltage/no voltage/voltage restored event. There can be peaks of excessive voltages at the corners. With all the uncertainties of a remote diagnosis I wouldn't rule out the possibility that the printers mb took a hit from something like that. And as you describe it the problems began after the outage.

Some motherboards have more than one usb port and there could be a chance of reconfig and use the other port. But generally I suspect that you'd need to replace the mother board. Again, a web search on your printer model will be really helpful.

Ah, Ender 3. Still the original Melzi board, 8-bit and noisy steppers?
Replacing the mb with a BTT Sk mini E3 would be an upgrade even with no usb problems.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.