One of the octoprint services (no out of 4) crashes randomly

What is the problem?

My printserver has 4 instances (I know it is not officially supported, or did it change??)
service octoprint2 randomly (at least once a day) becomes unavailable so I had to restart it manually
sudo service octoprint2 restart
This just did happen over night seems in the time period not being used.
But now a bigger print failed in the middle of it Printer just stopped
So the question is what happens has it to do with the serviece failed and therefore why does the service stopp and have I fix for it.

What did you already try to solve it?

Have extracted the section out of 2 restarts of the octoprin2 service inbetween the print fail happend and will attache
Print Failed octoprint2 service keeps crashing from time to (12.0 KB)

Have you tried running in safe mode?

Not jet but right now I will start a print on save mode. and will than let it rest over night in the safe mode if the print does not fail

Did running in safe mode solve the problem?

To be investigated

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

yes attached (89.3 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

1.8.7 0,17,0 rapberry pi 4 instances

It appears, that the Matrix Notifier has some trouble executing:

2023-05-03 11:38:30,553 - octoprint.plugin - ERROR - Error while calling plugin matrix_notifier
Traceback (most recent call last):
  File "/home/pi/oprint/lib/python3.7/site-packages/octoprint/plugin/", line 273, in call_plugin
    result = getattr(plugin, method)(*args, **kwargs)
  File "/home/pi/oprint/lib/python3.7/site-packages/octoprint/util/", line 1688, in wrapper
    return f(*args, **kwargs)
  File "/home/pi/oprint/lib/python3.7/site-packages/octoprint_matrix_notifier/", line 109, in on_after_startup
    user_id = self.client.whoami()["user_id"]
  File "/home/pi/oprint/lib/python3.7/site-packages/octoprint_matrix_notifier/", line 69, in whoami
    return self._send(method, path)
  File "/home/pi/oprint/lib/python3.7/site-packages/octoprint_matrix_notifier/", line 44, in _send
    resp = urlopen(req)
  File "/usr/lib/python3.7/urllib/", line 222, in urlopen
    return, data, timeout)
  File "/usr/lib/python3.7/urllib/", line 531, in open
    response = meth(req, response)
  File "/usr/lib/python3.7/urllib/", line 641, in http_response
    'http', request, response, code, msg, hdrs)
  File "/usr/lib/python3.7/urllib/", line 569, in error
    return self._call_chain(*args)
  File "/usr/lib/python3.7/urllib/", line 503, in _call_chain
    result = func(*args)
  File "/usr/lib/python3.7/urllib/", line 649, in http_error_default
    raise HTTPError(req.full_url, code, msg, hdrs, fp)
urllib.error.HTTPError: HTTP Error 401: Unauthorized


  • The OctoPi version is a bit out of date.
  • There are some Plugins marked as incompatible:
 | *SlicerSettingsTab (1.0.3) = /home/pi/oprint/lib/python3.7/site-packages/octoprint_SlicerSettingsTab
 | *Yamlpatcher (0.1.1) = /home/pi/oprint/lib/python3.7/site-packages/octoprint_yamlpatcher

I do not know what the matrix notifier does and from which plugin it comes
Can it be uninstalled or is it system internal.
thanks for the other plugins will try to uninstall and reinstall

since now I tried to get arround because the custamisationlevel is high and it would take a lot of time to setup everything from scratch

For the matrix Notifier:

Yamlpatcher won't work with Python 3

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.