Open Octopi Pi Camera Port 8080 instead of relative path /webcam


I have the octopi 0.18.0 image installed on a Raspi 3B+ and it is working fine with a raspi cam in cluding the camera stream in the octoprint tab.

This setup is at my work place. I am only allowed to stream the video through a port forwarding, wich is accessible from whole network at work. Not everyone should be able to access the octoprint gui from everywhere, but beeing able to check, if a print is ready or failed, etc..

The former solution with an olf version of Octopi was a port forwarding of 8080 to the whole network and port 80 only to a dedicated computer.

After a long time with google and in several forums I could not find, how to open port 8080 instead or additional to the relative path /webcam.

Can you help me how I can do this? Or is there a better method to achieve the desired behavior?

thx for your help

Uncomment camera_http_options in /boot/octopi.txt and it should work. You shouldn't have to change any of the settings there, just uncommenting it should be enough. When there's no options specified then it is restricted localhost by default.


Thank you very much for the quick and great answer! It works like a charm!