Password issue blocking noob on Raspberry 4 4GB

I downloaded the lastest v17 release, put it on a SD card using Etcher, edited the WiFi info, and it booted apparently OK.
I changed the password, on the Raspberry Pi 4 directly, for Pi@. It seems to have worked.
But when I try to ssh from my Mac, it gets confusing. It asks for password, which I assume is my Mac password in order to use ssh, but it doesn't seem to accept that. But after 3 tries it asks for the password for pi@, and so I enter the password I set it to on the RP4, but now ssh says the password isn't valid, and after a few tries it disconnects.
So confusion--which password is it looking for in the first tries after doing ssh, and what does it mean that it changes to asking for the password for pi@
I've tried many variations of which password I supply, and I have the impression that my normal password is not working for ssh, for the first 3 tries, yet it changes to asking for the password for pi@, and none of those work either.
This might be a Linux issue, but certainly it's a noob issue, and I don't know what to try next. Ideas?

Hello @DaveGadgeteer!

If you haven't done nothing else with that setup, I would begin from scratch with reimaging the SD card.
Actually, when you login via SSH to a fresh OctoPi, the standard ID & Password is pi & raspberry

If ssh on Mac is the same as ssh on Linux there are normally only two kinds of "passwords" ssh asks for:

  1. the ssh passphrase of your private key. There the question from ssh is for "passphrase" and not for "password". This passphrase is set when the key is generated but can be changed afterwards.
  2. if none of your private keys matches any public keys in authorized_keys on the remote computer, ssh may be asking for a "password" and this is the password of the user on the remote computer.

This is for a normal configuration, it can more complicated in the general case.

Edit: If you want to put your keys as autorized_keys on the rpi you can do it with (assuming Mac is like Linux :thinking:):

cat ~/.ssh/id*.pub | ssh pi@octopi.local 'mkdir -p .ssh && cat >>.ssh/authorized_keys'

US keyboard layout from commandline, another one via ssh?

If you have any keyboard layout on the CLI and you use ssh from it, the keyboard layout doesn't change while using ssh.