Password works for Putty Command Line But Not GUI


#1

What is the problem?
Brand new Octopi new install working fine, Putty from desktop working fine. Followed instructions to add GUI, seemed to work at first glance, I can still Putty in to the command line with same password, but if I try to login to GUI on actual pi my password doesn't work and also the default password doesn't work.

What did you already try to solve it?
Reboots, Lots of google searching, tried my password and default, tried logging in via Putty from desktop password worked. Only non-remote by GUI then password doesn't work.

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)


#2

These are actually two different logins. SSH and FTP use the raspbian login and the GUI uses the login you once set up when you started OctoPrint for the first time.
If you have lost/forgotten you GUI login, this may help you.

All this assuming you mean the OctoPrint web interface as GUI.


#3

Thank you for the help Ewald.

What I meant by GUI was not octoprint web GUI, but the raspian GUI for octopi, as discussed here https://www.raspberrypi.org/forums/viewtopic.php?f=66&t=133691.

Ultimately I'm not sure what my problem was specifically, but I changed my password in raspi-config and did some other updating and now my octopi successfully is running the raspian GUI. The reason I want to do this is that when at my printer I want to be able to use KVM to use the pi as more than just a print server. I may learn it is a bad idea for some reason, but that is what I intend to experiment with.

Thanks again,

Jay


#4

Yeah, don't do this, at least not while printing. The Pi isn't powerful enough to run a heavy desktop environment and reliably stream print jobs.


#5

Thank you for the advice. I thought I might learn that the hard way.

I also have a laptop that I bring to my print area. Often times I'll be watching video on the laptop while printing and wish I had a second computer there to watch the webcam on, because I have an improvised opaque enclosure. That's where the pi comes in. But maybe you just gave me the excuse I wanted to build a second pi haha.

By your warning I am inferring that I would not even want to even just watch the webcam on my pi while functioning as a print server? I was figuring it is a fairly powerful little computer and how hard can it be to stream g-code, but now sounding like I need a 2nd pi or maybe a cluster...this is getting addictive haha.


#6

The webcam stream alone would probably not be an issue. But in order to view the webcam stream in the desktop environment you'd already be talking about:

  • The x server running the GUI in the first place,
  • The desktop environment running on that,
  • Its window manager,
  • Whatever widgets are active in the taskbar and
  • The web browser displaying the stream.

That's a lot of stuff. Can work out. Or can't and then you have a ruined print. Personally I wouldn't risk it.


#7

Thank you.

I'll have to look at Joe Mike's tutorial vids again. I think he is running the GUI with a touchscreen on hi octopi, but maybe I misunderstood what he is doing. I'm brand new to linux this week, so I'm still connecting the dots.


#8

Aha, it took quite a bit of searching, but I found at the very end of one of his blog postst, "To get to the Octoprint server from the Pi’s web browser, type localhost into the address bar.". So evidently the touchscreen pi is not the octopi server.


#9

Hi, I have the problem you suspected OP had.

I installed and used octoprint from a clean install. Everythign worked. But then i wanted to change the network address to make connections easier and changed to old adress from 169.254.71.32 to 192.168.0.10 with nano per ssh. It works, i can ssh into my raspberry pi 3 with putty pretty nicely under the new ip. The old username "pi" still works with my self selected password. So the ssh into OS seems to work.

However, now i cannot log into the web interface of octoprint anymore.

I can open it in the browser, see all the files saved on the SD card and i can read the temperature of the printer and everything else that is a read only function. I hope that makes sense.
I cannot start a new print, because, when i click on the login button and enter the login and password (i am 100% sure they are right) i get the message that either password or login are wrong.

I am running OctoPrint 1.3.8 and OctoPi 0.15.1.
The sullution you sugested doesnt work, because (and i cannot belive it) the octoprint folder is empty. It contains a readme.txt and nothing else. Also i used the find command in the ssh shell and there is not a single .yaml file in existence.


#10

Hello @Heroinepuppy
nothing is lost yet.
So you have access though the back door with SSH - good.
You can start the GUI but you can not login.
Actually there is nothing more than the Readme.txt in the OctoPrint folder.
There is another folder .octoprint. Notice the dot on front of the name and all letters a small. This is a hidden folder. Just type

cd .octoprint

if you want to have a peek inside that folder.


#11

Hey, thanks for that hint, i didnt know linux does it that way. I will tell you if it helped!


#12

Wonderfull, thanks a lot for your help.


#13

If you're talking about what the Raspberry Pi 3B has for performance...

  • I've installed the "Desktop" (GUI) x server to my OctoPi-imaged Raspi
  • I've installed Conky to display system info on the TFT screen
  • The Conky script includes a variety of oddly-timed scripts which reach out and gather logistics from OctoPrint's API, being careful to not have simultaneously-running scripts
  • There's a webcam which streams video back to the client
  • I've installed NodeJS and I'm running an additional web service which listens to port 3000
  • And of course, there's the printer itself and the basic task of serializing the job to the controller board

The Conky interface shows me the four cores of the Raspi and how busy they are. I sometimes run the top command in a Terminal to see what is "heavy" from a processing standpoint. I rarely have any of the stuttering-related problems associated with the Raspi being too busy and my prints turn out great.

Overall, I'm impressed at how well all of this works on a $35 computer.