Pause action notification not working

What is the problem?

Hello all, I've just tested every combination of octoprint 1.5.2 and 1.6, marlin and marlin bugfix pulled this morning and I can't get host action notifications to work. when pressing pause on marlin, it says pausing on the marlin screen, I get a ui paused popup on octoprint, but octoprint doesn't stop sending gcode. I remember I had this working about 2 weeks ago so I really don't know what could be going on.

note: host start in marlin does get octoprint to start printing the loaded file

videos of 4 tests: Host Action Notification Tests – Google Drive

What did you already try to solve it?

using Marlin release and bugfix pulled this morning and on April 15th
using octopi 0.18.0 and custom installed octoprint 1.6.0

Have you tried running in safe mode?

yes, through all testing

Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!) (73.9 KB)

additional bundle taken on freshly updated octopi 0.18.0 (octoprint 1.6.0) with serial logging enabled this time - Marlin (32.4 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

1.5.2 & 1.6 tested
BTT SKR Mini E3 V2

Might be useful to have your Marlin configuration.h and configuration_adv.h as well. (74.3 KB)

I don't see Marlin sending an action command to actually pause there, only a notification and a prompt, neither of which pause a print on their own.

There should be a //action:pause in there somewhere but there isn't and that would explain why OctoPrint keeps on going.

I reported this yesterday :slight_smile: [BUG] (//action:pause not being sent when paused from marlin lcd) · Issue #21737 · MarlinFirmware/Marlin · GitHub

Unfortunately I got shut down because someone didn't entirely read it :frowning:

Haven't followed the entire path but you might need HOST_PROMPT_SUPPORT when using ADVANCED_PAUSE_FEATURE since it requires user interaction.

I don't want to use advanced pause feature for that exact reason

Then disable it..?