Pause script did not receive parseable position data

What is the problem?

pause script did not receive parseable position data.

Pause script, found in Octoprint community GCODE scripts returns
"Did not receive parseable position data from printer within 10.0s, continuing without it"

> Send: N2216 G1 X205.058 Y163.118 E96.3081*86
> Recv: ok
> Send: N2217 G1 X205.345 Y162.830 E96.3223*80
> Recv:  T:210.00 /210.00 B:55.94 /55.00 @:63 B@:0
> Changing monitoring state from "Printing" to "Pausing"
> Recv: echo:busy: processing
> Recv:  T:210.16 /210.00 B:55.94 /55.00 @:44 B@:0
> Recv: ok
> Send: N2218 M400*30
> Recv:  T:210.00 /210.00 B:55.94 /55.00 @:78 B@:0
> Recv: echo:busy: processing
> Recv:  T:210.00 /210.00 B:55.89 /55.00 @:36 B@:0
> Recv: echo:busy: processing
> Recv:  T:210.00 /210.00 B:55.83 /55.00 @:52 B@:0
> Recv: echo:busy: processing
> Recv:  T:210.00 /210.00 B:55.78 /55.00 @:34 B@:0
> Recv: echo:busy: processing
> Recv:  T:210.00 /210.00 B:55.63 /55.00 @:68 B@:0
> Recv: echo:busy: processing
> Did not receive parseable position data from printer within 10.0s, continuing without it
> Recv:  T:209.84 /210.00 B:55.57 /55.00 @:100 B@:0
> Recv: echo:busy: processing
> Recv:  T:210.00 /210.00 B:55.47 /55.00 @:58 B@:0
> Recv: echo:busy: processing
> Recv:  T:210.00 /210.00 B:55.42 /55.00 @:76 B@:0
> Recv: echo:busy: processing
> Recv:  T:210.16 /210.00 B:55.31 /55.00 @:49 B@:0
> Recv: echo:busy: processing
> Recv:  T:210.16 /210.00 B:55.26 /55.00 @:19 B@:0
> Recv: echo:busy: processing
> Recv:  T:210.00 /210.00 B:55.05 /55.00 @:76 B@:0
> Recv: echo:busy: processing
> Recv:  T:210.16 /210.00 B:55.00 /55.00 @:45 B@:0
> Recv: echo:busy: processing
> Recv:  T:210.16 /210.00 B:54.89 /55.00 @:16 B@:0
> Recv: echo:busy: processing
> Recv:  T:210.00 /210.00 B:54.83 /55.00 @:60 B@:127
> Recv: ok
> Send: N2219 M114*31
> Recv: X:205.35 Y:162.83 Z:1.31 E:96.32 Count X:16428 Y:13026 Z:526
> Recv: ok
> Changing monitoring state from "Pausing" to "Paused"
> Recv:  T:210.00 /210.00 B:55.05 /55.00 @:37 B@:127
> Recv:  T:210.00 /210.00 B:55.36 /55.00 @:19 B@:127
> Recv:  T:209.84 /210.00 B:55.68 /55.00 @:54 B@:0

What did you already try to solve it?

Log position on pause in Octoprint Behaviour is ckecked;
M114 is added into the list of Long running commands

Despite of these settings, Istill have an error message from Octoprint, because the answer takes too much time to come.

And, I know why ! :slight_smile:

On large prints areas , with long lines to print, the 10 seconds allowed to Octoprint to received M114 answer is not enough (because of printing lines in buffers and because of the time to print and purge them)

All can be resume in these few words :

Did not receive parseable position data from printer within 10.0s, continuing without it

:point_right: within 10.0s is the gulty one here

Is there a way, or a chance to have a fix for a future option to increase this allocated delay ?

All is working fine on small prints area, but on large one, these ten seconds are the problem.

Thanks for reading !

Systeminfo Bundle

System Info

Additional information about your setup

OctoPrint version : 1.9.3
OctoPi version : 1.0.0
Running on : Raspberry Pi 4
Printer Ender3 pro / SKR V1.3 / Marlin 2.0.9.2

You might be able to precede the M114 command with M400. This will tell the printer to complete all moves in buffer prior to continuing the next command.

1 Like

Hey :raised_hand_with_fingers_splayed:

Sure, and code is already sent (above on line 2218)

Send: N2218 M400*30

But still, 10 sec are too short for the answer to Come on these particular prints with large flat areas :pensive:

you could just extend the timeout for position reporting.

2 Likes

What idiot am I.

Asking for a fix to extend this particular delay, option that is already in :pensive:

Sorry that I couldn't find it by myself !

Thanks a lot :+1:

1 Like