Paused Print, Fails to Restart

What is the problem?

When pausing a print through the WebUI, the print fails to resume and just continues to spew filament. The print it happened on was a 24hr+ print job that was ~65% finished.

What did you already try to solve it?

Nothing. I was at work watching my prints via TeamViewer

Have you tried running in safe mode?

Not yet.

Did running in safe mode solve the problem?

Haven't tested yet.

Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)

Printer Logs:

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Printer: Ender 3

Browser: Version 88.0.4324.150 (Official Build) (64-bit)
Operating System: Windows 10 Pro

browser.user_agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/88.0.4324.150 Safari/537.36
connectivity.connection_ok: true
connectivity.enabled: true true
connectivity.resolution_ok: true
env.hardware.cores: 4
env.hardware.freq: 1200
env.hardware.ram: 917016576
env.os.bits: 32 linux
env.os.platform: linux2
env.plugins.pi_support.model: Raspberry Pi 3 Model B Rev 1.2
env.plugins.pi_support.octopi_version: 0.17.0
env.plugins.pi_support.throttle_state: 0x50000
env.python.pip: 19.3.1
env.python.version: 2.7.16
env.python.virtualenv: true
octoprint.safe_mode: false
octoprint.version: 1.5.3

Hello @binarydata !

So, how are your settings for pause/resume in the OctoPrint settings?

Your serial.log is empty. You may enable it first.

You are printing from SD card, yes?

2021-02-14 23:49:16,642 - octoprint.util.comm - INFO - Changing monitoring state from "Printing from SD" to "Pausing"
2021-02-14 23:49:30,011 - octoprint.util.comm - INFO - Externally triggered heatup detected
2021-02-14 23:49:37,329 - octoprint.printer.standard.job - INFO - Print job paused - origin: sdcard, path: sbrf~1.gco, owner: dreadstarx, user: dreadstarx
2021-02-14 23:49:37,427 - octoprint.util.comm - INFO - Changing monitoring state from "Pausing" to "Paused"
2021-02-14 23:49:38,011 - octoprint.util.comm - INFO - Externally triggered heatup detected

Well, there are no settings there. So that's a problem to fix, I figured there was AT LEAST basic pause/resume settings by default, but I was wrong to assume that.

Serial Log is enabled.

Printing from SD Card, but it looks like the first comment is what's wrong. I'll have to research this more. I was monitoring it remotely, I was getting low on filament and wanted to pause it before I ran out so I could install the next spool.

There's a big fat warning in the docs explaining why there aren't :wink:

1 Like

I've been learning 3D printing / octoprint on the fly. I spoke up at work about an idea, and mentioned I had a 3D Printer. That translated to "He can do all of this and more for us..." At least I'm getting reimbursed for filament.