Persistent reboot on each gcode file upload

Upload failed

Could not upload the file. Make sure that it is a readable, valid file with one of these extensions: .g, .gco, .gcode

  1. Nothing in logs
  2. Cancel Object plugin not enabled
  3. Octoprint worked for years and now this
  4. Tried to update to latest version but did not help

Is this a known problem? Best option to reinstall octoprint?


If there is really nothing in the logs (which I can't check because you didn't provide them) I would take a wild guess and say the sd card is broken.

1 Like

Try safe mode, to check it is not a plugin.

Thanks Guys for this quick reply. I already tried safe mode with same result.

I suspect this may be broken sd card. Ill try to replace it and update you here.

Thanks again!

Ok this has been the weirdest prob I experienced ever and seems to be linked to the Windows.

  1. On my desktop PC, when I uploaded any gcode file, I received the above error message. I tried it via Chrome, Mozilla, IE, rebooting, clearing cookies, replacing raspberry pie, sd-card, reinstalling octoprint, reexporting gcode files etc. Nothing helped.

  2. But when I later tried to load a gcode file to the same raspberry pie from my another computer - everything worked fine.

So I reinstalled my Windows 10 and all is back to normal.

Thanks to you Guys for your speedy responses and beware of M$ products, for they will shorten your life!