Phone cannot connect to printer


I hope someone can help me with this issue as I'm a proper beginner when it comes to OctoPrint set-up... I was reading in the forum here but couldn't find a solution yet.

I've installed OctoPrint (1.1.0) on my android phone (Samsung S9) trying to run it as OctoPi. I can access it from my laptop and instal Plugins etc., but it cannot connect the printer (Prusa MK3S+) to my phone.
I can see only Serial Port Options 'AUTO' and '/dev/ttyOcto4a' so I suspect there is no connection to the actual port from the printer

Taken steps:

  1. I use the original cable that comes with the printer. It seems to work as I connected the cable directly to the laptop and the printer can be managed through the laptop via Pronterface
  2. Tried running OctoPrint in 'safe mode' and see two additional ports available '/dev/ttySAC0' and '/dev/ttySAC1'. I tried to connect to them but it doesn't work.

Here is the Systeminfo Bundle attached. As I mentioned I'm a beginner so not really sure how to read the info in it. (63.7 KB)

I also saw people recommended running dmesg with the connected and disconnected printer but not really sure how to do that. When I go to '>_Terminal' menu, I'm not allowed to type anything.

Additional info: I'm using USB-C hub to charge and connect the phone to the printer.

Thanks in advance for your support

In the Octo4a app (not OctoPrint) there should be an option to select the printer/USB connection there. /dev/ttyOcto4a would be correct in the OctoPrint UI.

Thanks @Charlie_Powell

Do you mean here (as per the screenshot)?

Unfortunately, I have no option to choose anything in Octo4a when the printer is ON and connected to the phone

That was the place I was meaning, yep.

It says no printer connected, which means Octo4a is unable to see the printer. If there are no options there to connect to then you will have no luck in OctoPrint.

Some phones can't charge & transfer data at the same time apparently, on many there is a menu/option to select the USB mode which may be of use. Otherwise I can't help much I'm afraid.

Have you tried different cables?
Some only transfer power, but no data.

Hi guys,

Thebks for your inputs and sorry for my late reply… unfortunately day to day stuff have gotten on way

An update: I managed to connect the printer to the phone via the USB-C if I plug in the printer first, then when I add the charger the phone doesn’t charge.
If I plug in the charger first, the phone is charging but the printer doesn’t connect.
Based on the suggestion from @Charlie_Powell I think you’re right and the phone cannot charge and transfer data simultaneously from two sources..

Do you by any chance know a work around for that issue? Or the solution is simply to use another android phone?

Did you solve the problem @Ivanovm7?

I have same problem with rooted Samsung Galaxy S9- i can't connect with printer when phone is charging, and while i'm connected to printer i cant charge phone.

I'm using: this cable

My phone is flashed with Odin

@Wildmor I tried with various cables and couldn’t solve the problem…
I think the newer android versions have blocked this functionality.
I found older Samsung phone (android 7or 8) and it works with it

I have the same problem with it not connecting to the printer. I am using the same cable that I was connecting to a pc and it worked fine. I have tried it with charging from the hub and without, it still won’t connect. I can see the camera but that’s all.