Pi 3 B+ with v2 Rpi camera stream won't start


#1

What is the problem?
I got the right B+ model now - with wifi and bluetooth. Turned it on and connected to wifi right away and booted into Octoprint. I connected my v2 RPi camera and there is no stream at all.

What did you already try to solve it?
I tried disabling some plugins I downloaded for time-lapse (Octolapse) and rebooted, removed camera cable and reinstalled it. Rebooted the Pi.

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)
I get the "Webcam stream not loaded" error when I click on the tab to view the camera. Not sure what else to provide here or what logs to look at. This same camera was just working yesterday on a Pi 1 B+ model from 2014. Don't think it could be the camera. I am sure it is a setting or something but I am not sure where to look or what to change. Any suggestion would be greatly appreciated.


#2

I did try a fresh install and configuration but the camera still shows nothing.


#3

Windows? What browser? IE11 has a problem with the OctoPrint stream. All others I've tried work OK, including Edge.


#4

Did you enable the camera in raspi-config?


#5

I am using a Mac so I am using Safari and also trying on my phone thru Safari as well the Octoclient app. I did remote in via SSH and went into Raspi-config and made sure camera was enabled. I also went into octopi.txt and changed the camera from auto to raspi. So far it still gives me the same web stream won't start. I am beginning to think it may be something on my router blocking the 8080 port but I can't see anything setup like that when I log into my router admin screen.


#6

I also went in and checked the webcam.log and got this - not sure if it is helpful or provides any further insight.

Starting up webcamDaemon...

--- Configuration: ----------------------------
camera: raspi
usb options: -r 640x480 -f 10
raspi options: -fps 10
http options: -w ./www-octopi -n

No camera detected, trying again in two minutes
No camera detected, trying again in two minutes


#7

I guess I should ask a stupid question (stupid because I've done it :smiley:) Are you sure you got that flat cable plugged in the correct way? I wish there was a notch or something that prevented it from being plugged in upside down.


#8

I thought the same thing, but no - that is not it. I checked and the blue side is away from the hdmi port. I even double checked to make sure i had it plugged in to the camera port and not display. No matter what I do - nothing happens. It has to be a bad cable, bad camera or bad Pi - but I do not have any extra around to check any of those out. All I know is that two days ago the camera and cable worked on a different board and today no camera. When I power on there is no led I an see on the camera (v2.1 raspi). Not sure ifthere is any way to check the board via SSH or something to get a positive as to whetherthe port is working or not? Ihave a coworker that is bringing in a board Monday and we will try the camera and cable on that one. Until then - I haveno idea what to do.