Pi 3 Model A+ unable to boot latest OctoPi stretch image 0.15


#21

Could you run that ifconfig locally on the Raspi and provide the output here? Thanks.


#22

Yes, I can run that but is there an easy way to copy the output. I am just looking at a terminal window and using a Rii bluetooth keyboard. I can't cut&paste to my PC and I can not get telnet to work.
Is there anything specific in the output that I should look for?
There is also something new. Now at the end of the boot sequence where it shows the URLs to use for the browser, there is one entry. http://octopi.local
However, when I try to access it I get "The site can't be reached" and I don't see Octoprint or Raspberry on the network.


#23

I guess there's a bit of a cart-and-horse problem here. Until you get a network adapter working, you'd not be able to easily transfer output over to here on the forum.

Compare this one, I suppose. Note that I have a Raspberry Pi 3B so it includes an eth0 Ethernet adapter which is currently unplugged.

pi@octopi:~ $ ifconfig
eth0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether b8:27:eb:8b:f2:92  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 8578  bytes 1426435 (1.3 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 8578  bytes 1426435 (1.3 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 10.20.30.250  netmask 255.255.255.0  broadcast 10.20.30.255
        ether b8:27:eb:de:a7:c7  txqueuelen 1000  (Ethernet)
        RX packets 14962  bytes 1033846 (1009.6 KiB)
        RX errors 0  dropped 3  overruns 0  frame 0
        TX packets 111588  bytes 169222392 (161.3 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

The wlan0 section is most important for you. It needs to be UP and RUNNING and an IPv4 address bound to it.


#24

Interesting. I have two blocks. The first is lo: and top line is: inet 127.0.0.1 netmask 255.0.0.0
The other entry is wlan1 (there is no wlan0). Flags = 4099<UP,BROADCAST,MULTICAST> mtu 1500
However there is no IP address line. Instead there is a line : ether b8:27:eb:f6:ab:49 txqueuelen 1000 (ethernet)
The packet entries for errors, bytes etc are all 0.
I can check back tomorrow but for now I have a date with AC Odyssey :slight_smile:


#25

lo is the one associated with the word/hostname localhost. Locally on the Raspberry if you had the Desktop loaded in theory you could visit http://localhost and it would serve up OctoPrint. From a terminal locally on the Raspberry, you could still do curl -v http://localhost/ and it should display the header conversation and then the HTML itself for the home page. (That is, it would do this if haproxy is successfully moving things from tcp port 5000 over to port 80 and if OctoPrint is running on port 5000.)

Oh... note that it's wlan1 rather than the expected wlan0. Hmm... I wonder if this is new to the A+? Try going into sudo raspi-config -> 2 Network Options -> N3 Network interface names. Mine is currently set to "No" as the default. It would be interesting to see if yours is set to "Yes" here.

If you're missing the RUNNING flag and there's no IP address assigned, then you really have no wi-fi adapter bound, as guessed earlier.

Is OctoPrint running? ps -ax|grep octoprint

pi@octoprint:~ $ ps -ax|grep octoprint
22215 ?        Sl     0:59 /home/pi/oprint/bin/python2 /home/pi/oprint/bin/octoprint serve --host=127.0.0.1 --port=5000

This confirms that octoprint is running on port 5000.

Is haproxy running?

pi@octopi:~/ $ ps -ax|grep haproxy
  625 ?        Ss     0:00 /usr/sbin/haproxy-systemd-wrapper -f /etc/haproxy/haproxy.cfg -p /run/haproxy.pid
  631 ?        S      0:00 /usr/sbin/haproxy-master
  633 ?        Ss     0:04 /usr/sbin/haproxy -f /etc/haproxy/haproxy.cfg -p /run/haproxy.pid -Ds

This then moves things from the default port 80 http port over to port 5000 for OctoPrint.


#26

Network Options/Network Interface Names is set to No. I left it that way.
Grep for octoprint. Yes, it is running on port 5000 (127.0.0.1) exactly as in your post.
Grep for haproxy. Yes. 3 lines, exactly the same as in your post
Should I try update and upgrade? At the moment I think this is running unmodified from the nightly image but it could be that it is fixed by update/upgrade.


#27

It feels like this has something to do with that wlan1 oddity rather than anything you might have done during the setup. I'm sure there's a way of doing a udev which puts things the way they're supposed to be but this has me scratching my head.

Assumptions

  • You have not added a USB wi-fi dongle of some kind
  • Your existing /etc/wpa_supplicant/wpa_supplicant.conf file looks something like:
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=US

network={
	ssid="YourCaseSensitiveSSID"
	psk="YourCaseSensitiveWiFiPassword"
}

The problem seems to be entirely centered around the wi-fi adapter not being recognized somehow with wpa_supplicant and receiving an IP address. Feel free to start over but this feels like something weird with the A+ so far...


#28

OK. Now I feel like an idiot!
The ssid had a typo.
Everything now works and octoprint loads successfully from the browser. URLs show up as expected.
I'm just gonna step outside and scream......
Thanks - it's been fun. Hopefully it is useful to know that the latest nightly works completely, provided the edits to wpa_supplicant.conf have been done correctly!


#29

That's the fun of the A+ since it doesn't also include a standard Ethernet connection: the wi-fi either works or it doesn't.

At least you figured it out by getting on there locally. Enjoy your setup now that it's happy. :slight_smile:


#30

... and for anyone that wants confirmation, it's printing very well (to my CR-10) with no stuttering on circular sections. Overall, the time for prints seems a bit longer than directly through Simplify3D and USB but I need to do some more comparison testing when I get time to be sure of the difference. I'm relieved to be back to printing through Octopi.