Pi 3 Model A+ unable to boot latest OctoPi stretch image 0.15


#1

What is the problem?
I have created an SD card using the latest OctoPi Stretch Lite 0.15 image. It does not boot on this latest model Raspberry Pi 3A+, recently released.
The symptom is that the display only shows the rainbow box image (full screen, NO lightning bolt at the top RHS) and only the red power LED is lit. The boot sticks at this stage.
What did you already try to solve it?
Tried creating the image (With Etcher - latest version) several times using different SD cards. Fault remains the same. Created a Raspbian only image (Stretch full) and it booted successfully.
I tried to install OctoPi manually under Raspbian using two different methods, by single command line and by fully scripted method). Neither worked. On each occasion a WiFi scanner showed OctoPi on the network but there were no open ports and no http access. Attempts to start or restart the octoprint service reported that it was not found. I also could no locate a running Octopi process by grepping it from ps -ef command.
Ideally the OctoPi image should boot successfully but the error indicates that the kernel image file is not being loaded. I don't understand why this is as the full Raspbian image boots successfully.
I tried copying the Kernel.img files between images but it still didn't work.
Has anyone else obtained one of these new Raspberry Pi Model 3A+ devices and tried installing OctoPi from the boot image or manually? I would love to hear from you if you had any success.
Is it possible to access other OctoPi images? If so I could try some different versions but I could find no way to download anything other than the latest stable image.
Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)
Brand new Raspberry Pi 3 Model A+ with latest OctoPi stretch lite image.
Unable to boot. Because nothing boots there is no log to look at (as far as I am aware)


#2

Hi @Al_Wilson!

The Raspberry Pi 3 A+ is quite new. Newer than OctoPi 0.15.1
So it is to assume that the included OS with OctoPi 0.15.1 is not quite compatible with the new RasPi.
The recent OS on the Raspberry Pi site are also only a few days old.

If you like to run OctoPrint on your new RasPi 3 A+, you may install Raspian (OctoPrint usually does not need the Raspian Desktop) and then OctoPrint as described here.


#3

Neither @guysoft nor me have access to one of those things yet.

You could try a nightly, those are built against the most recent image AFAIK. Alternatively try booting on an earlier model, run a full firmware and system update and then see if it now boots on the 3A+.


#4

Ewald: Thank you. I tried the manual install of OctoPrint from that description. Unfortunately it did not work. The symptoms were described in my original post. However, I will try again :slight_smile:


#5

Many thanks for your suggestions. I will try a nightly build. Actually, the full OctoPi image did work on an earlier basic model Pi that I normally use for 3D printing. However, it is much too slow so I wanted to try this latest model. I'll try again after updating - I hadn't thought of that!


#6

I just sudo rpi- update my old B+ image and works fine on the A+


#7

Cool. You got the A+ to work! Many thanks Paul, I'll give that a try! I couldn't get my old image to work because my old Pi uses a large format SD card and the new one is a micro SD. I tried just copying the files between them but it didn't work - should that work? I wasn't sure that an SD made just by copying files would be bootable.


#8

Don't you have an adaptor for the micro SD to normal size SD?


#9

Yes. I can put the micro sd into the adapter to use on the old model Pi. That works. At the moment I have this in the old Pi and have done a sudo apt update. I am now running a sudo apt upgrade and there are a lot of upgrades taking place, including the kernel files. When it's finished I will try this image in the A+ and then update this post.


#10

Good luck with it. I wish, you succeed!


#11

Thank you. Your wish worked :slight_smile:
After completing the update and upgrade I put the micro usb into the A+ and it booted up fine. Octoprint was found (at a different IP address) and the browser loaded to the setup wizard. I'll have to reload my config and plugins but that's no problem. I'll be testing a print later this afternoon.
Thanks to all for replies and suggestions. It's been a good learning experience. Now maybe I can help others who have the same problem I did.


#12

Keep in mind that it has half the RAM (512K) so you might want to keep an eye on the memory usage. It may page swap more as a result. Watch for stuttering on small curved parts.


#13

That's a good point. I was already suffering from that on my old Pi. It was so bad that I swapped to printing direct from PC (Simplify3D). I am hoping that this will be faster. Not yet tested as I'm trying to figure out how to add the OctoPi upload folder as a network location on my PC. I had it working on the old Pi but so far the new one can't be seen on my network. Not sure why, but it might be the same reason why I can see OctoPi on my network but I can't see Raspberry Pi. With my old Pi I saw both and used the Raspberry one for Telnet via ssh.


#14

If this is a Windows-based PC then this might be useful. And there's always this for name resolution.


#15

Raspberrypi Foundation released a new image last week (2018-11-13), next nightly would use it and should support A+, I think.
They retroactively edited their image before that release notes to write that it does support A+. So really need your help on testing this stuff out because RaspberryPi foundation will not give us a straight answer.


#16

I have a spare SD card so I'll download the latest nightly build and test it on the A+.
I'll report back when I have confirmed whether it boots successfully or not.
In the meantime I have confirmed that booting the stable OctoPi stretch lite image on an 'old' Pi and then performing the Updates and Upgrades will create an image that boots successfully to the A+. It's how I got mine to work thanks to help from this forum.


#17

I can confirm that the latest nightly build (2018-10-09-octopi-stretch-lite-0.16.0.img) boots successfully on the A+
At the moment I can confirm that OctoPrint is available on my network but I have not yet managed to load the browser. I think it's a network problem, as a sudo apt upgrade tells me thatthere is a failure resolving raspbian.raspberrypi.org

I'll try with my other working image to confirm whether I have a local network issue or whether there is a network problem with the image. However, I can confirm that this nightly image boots successfully, which the older stable version didn't.


#18

OK. The stable version of OctoPi I made by updating and upgrading on an older model Pi works fine so I don't have a local network problem. With this working version I see at the end of the boot process where it says that a web browser can be open using any of the displayed addresses. It then shows three URLs that will open OctoPring in the browser.
The nightly build completed the boot sequence and displays the same text about using any of the following URLs but NO URLs are shown.
I can only surmise that there is an issue associated with placing OctoPi onto the network.
I might not get any further but I'll pass on anything else I find (as I have other work to do as well :-))
The fact that this nightly build boots is a big positive. Other users more experienced might be able to work out the network issue.


#19

If no URLs are displayed there then tcp probably didn't bind to any of your wi-fi network adapter (since there's no Ethernet adapter in this model).

Try a local ifconfig to confirm.


#20

This only happened on the nightly (0.16.0) build. My internet worked fine and the stretch octopi version 0.15.1 worked fine after updating and upgrading and I have used it to print a case for the 3A+. The issue with missing URLs only happened with the nightly 0.16.0 build.