Pi 4 no wifi connection

What is the problem?

Pi 4 with octoprint doesn't connect to wifi

What did you already try to solve it?

Reloaded the .txt file and used the recommended text edit app to change the settings for wifi. Uncommented the WPA section and inputted my info, Uncommented my country and commented the factory country.

Have you tried running in safe mode?

Don't think I've got that far yet.

Did running in safe mode solve the problem?

See above.

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

I have no idea what this is.

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible


When you say the .txt file - do you mean you created/edited wpa_supplicant.conf on the SD card before you tried to boot it in a Pi?

If you did this in Windows, you may find that your file is actually called wpa_supplicant.conf.txt, in which case it won't work (I've been caught out by that before) - easiest way to check is to open a command prompt and dir the directory the file is in.

If it is correctly named, then can you paste the contents of the file here so I can check it's correct?

When you say "Pi 4 with octoprint" does that mean you flashed octopi to the sd-card?
And "the .txt file" was octopi-wpa-supplicant.txt?
Did you check your router's listings whether a new device registered there?
Did you plug a HDMI-monitor to the pi so you can read the boot messages?
Did you try to connect the pi with an ethernet cable to your router?

I flashed octopi to the SD card.

I edited the "octopi-wpa-supplicant.conf" in one of the recommended text editors and saved it. I uncommented what I needed to, I made sure to enter the correct ID and password, and I uncommented my country code whole commenting the factory country code.

I checked my router's listing and none of the devices on my network have my pi's name on it.

I have the pi plugged into a 720p monitor to see what it was doing after it didn't show up on my network.

If you are connected up to a monitor with a keyboard, log in to the Pi (username pi, password raspberry unless you changed it) and try some things:

Enter sudo iwlist scan wlan0 | grep SSID and see if your WiFi network is in the list, so that we know it is getting a good enough signal.

If your network is in the list, try running sudo raspi-config and entering the network details via the TUI that shows up, see if this works.

Was anything connected to the pi via usb?