Pi 4 or Plugins not passing the vibe check

I just recently got the Pi 4 for an Octoprint server it worked well for a few days but it seems to be corrupted. I couldn't update or add other plugins and I would say to check logs but the logs never generated. I tried reloading a backup and it totally bricked the OS. So I put a new buster image on it and put my norm alplugins on. (pushover, prusa leveler, PSU control, filament change, cost estimation and print time genius) and now it won't let me update Octopi an the SSH sessions are all wonky. I'm not sure if the problem is the Pi 4 or the plugins

so just raspbian? not the octopi image?

were you able to update before you installed the plugins?

do you mean like in the picture?
yeah seems like the welcome message is broken. could be because of a failed backup restoration.
update and upgrade are no valid commands.
what were you trying to do? update raspian? use sudo apt update && sudo apt -y upgrade instead :slight_smile:

1 Like

It was the Octopi Image.
I had installed the plugins then after that attempted to update the server through the Web UI and that's where that message is from. I had rebooted a few times and had the same issue. Those commands I know were incomplete just SSH'ed into is and revived that and couldn't remember the right ones the only command It did take is the sudo reboot and now its not coming backup (I remote into a computer at my house to manage it while prints are going) Ive had a similar set up on the Pi3 and have had no issues It seems like It may be the Pi but the power-supply is adequate according to The Pi foundation

  1. flash the OctoPi IMG file to the microSD
  2. edit the /boot/octopi-wpa-supplicant.txt file as necessary
  3. boot it
  4. remote into it with ssh pi@octopi.local
  5. sudo apt-get update && sudo apt-get -y upgrade
  6. sudo raspi-config # Update timezone, wifi country, default language
  7. sudo reboot

Test it without adding any plugins whatsoever. If it's happy for a day then add one plugin at a time, rebooting between each and testing.

1 Like

^this and I wouldn't restore this backup anymore.
It seems like it's either incompatible or corrupted.

It has to be my combo of plugins causing this issue because the It will work fine with vanilla octopi but when installing plugins (rebooting after each install) I begin to have this issue again

Okay, so now disable the plugins in the reverse order and test each time.