PI 4 - USB camera issues and Serial Exceptions

What is the problem?

  1. Serial exceptions when using Pi4 2GB wtih Octoprint 1.5.2
  2. Webcam issues after every print

Creality Ender 5 Plus Printer running 1.7.1 KF (Marlin Firmware) Some prints pause and then fail and the reported error is Serial Exceptions. Happened since upgrading to 1.5.X Some prints fail faster than others

On a couple of occasions, I have Chrome open on the Octoprint page, and when switch back to it with the web browser I am able to trigger the issue, or atleast thats when the browser updates and I can see the issue reported. Printer sits behind me so I can hear when its stopped ahead of checking the webcam footage, however, when I have refreshed the browser, twice now the print has then paused, and the Serial Exception error has occured.

Web browser is Chrome

Using Webcamd and service restart I can recover the Webcam issue.

What did you already try to solve it?

Rebooted Pi
Rebooted Printer
Changed USB cable
5V pin removed from cable

Have you tried running in safe mode?

Tried running in safe mode and the problem has happened again, and Octoprint is reporting same again.

Did running in safe mode solve the problem?

No it did not. I have downgraded from 1.5.2 to 1.4.2 and then run in safe mode and the problem persists

Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Log attached
octoprint (1).log (111.0 KB)

Just downgraded to 1.4.2 and had the same thing happen again:
" State: Offline (Error: Too many consecutive timeouts, printer still connected and alive?)"

Have changed USB port and rebooted, but, has had no effect. Problem persists. I am going to go back to a Raspberry Pi 3B with a fresh octoprint install and see if that solves the problem, will keep the PI4 and current SD card intact so that I can help troubleshoot further if requested.

First successful print moving to the PI3b with 1.5.2 installed with no plugins. Will start to add the plugins and see if it continues to be successful.