PI 4B (64bit) 8gb no wireless connection Octo-V18

Unable to connect wirelessly. Everything works fine wired, but no wireless connection.
Raspberry Pi 4B, 8GB

Tried walking through the tutorials, videos, and forums.
Country code is correct, login details are verified (attached), and IP address doesn't show up on boot wireless.

browser.user_agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/87.0.4280.88 Safari/537.36
connectivity.connection_check: 8.8.8.8:53
connectivity.connection_ok: true
connectivity.enabled: true
connectivity.online: true
connectivity.resolution_check: octoprint.org
connectivity.resolution_ok: true
env.hardware.cores: 4
env.hardware.freq: 1500
env.hardware.ram: 8141459456
env.os.bits: 64
env.os.id: linux
env.os.platform: linux
env.plugins.pi_support.model: Raspberry Pi 4 Model B Rev 1.4
env.plugins.pi_support.octopi_version: 0.18.0
env.plugins.pi_support.throttle_state: 0x0
env.python.pip: 20.2.4
env.python.version: 3.7.3
env.python.virtualenv: true
octoprint.safe_mode: false
octoprint.version: 1.5.2

It looks like (zooming in to the screenshot) that you might be missing the " quotes on the end of the password?

Thank you Charlie,
You were correct. This was the third attempt at re-burning the boot micro-sd, and I did miss a quote. I've fixed that and rebooted, but still no wireless connectivity at all.

I'm very new to all this, and quite frustrated.

I just installed the "official" Raspberry Pi OS to test all of my hardware, and the Wi-Fi imediately works flawlessly. I can conclude the hardware is all good.
Must be something I'm doing wrong with Octoprint install, or something with Octoprint itself?

Do you have a dash after country or an equal sign?

It is definitely nothing with Octoprint itself as there are thousands of users using that image around the world without a problem. If you are flashing the OctoPi image to the SD card, there must be something that you are putting in incorrectly. Also, your wifi passpharse in your screenshot looks like it's missing some ltteres, that is if you are using a real phrase. topotthemorning? Were you trying for tospotthemorning?

When you are putting in quote marks, what button are you using on the keyboard?

Do you have a keyboard and monitor hooked up to your pi? If so, you can forgo the wpa supplicant method and just use Raspi-Config to set up your wifi connection.

Thanks Ryan,
Yes, that is a crappy screenshot. I pulled the card and copy/pasted it here for better clarity.

## WPA/WPA2 secured
network={
  ssid="Wi-Fry"
  psk="topofthemorning"
  scan_ssid=1
}

## Open/unsecured
#network={
#  ssid="put SSID here"
#  key_mgmt=NONE
#}

## WEP "secured"
##
## WEP can be cracked within minutes. If your network is still relying on this
## encryption scheme you should seriously consider to update your network ASAP.
#network={
#  ssid="put SSID here"
#  key_mgmt=NONE
#  wep_key0="put password here"
#  wep_tx_keyidx=0
#}

# Uncomment the country your Pi is in to activate Wifi in RaspberryPi 3 B+ and above
# For full list see: https://en.wikipedia.org/wiki/ISO_3166-1_alpha-2
#country=GB # United Kingdom
country=CA # Canada
#country=DE # Germany
#country=FR # France
#country=US # United States

### You should not have to change the lines below #####################

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

When you copy paste, you have to use the code symbol, image to format it correctly. Highlight the text that is code and then hit that button in the editor.

If you already have a keyboard and monitor hooked up to your pi, don't worry about using the supplicant file. Just set it up in Raspi, config. Type the command "sudo raspi-config" and then follow the prompts on the screen.

And sorry...I just got your passphrase. I must need an afternoon coffee or something. LOL

Thanks for the tips. Still figuring this out.

I do have a keyboard, mouse, and monitor attached. I've also connected via the DOS prompt and Putty while connected by LAN.
I have little doubt my problems are my own doing, I just have zero idea now what else to try (or how) as a complete noob.

FYI, it's actually a bash prompt. DOS is for PC-land. You're in Linux country now! :wink:
Return your supplicant file to the way you found it with everything commented out. Then, from the prompt, type in sudo raspi-config
From the next menu, select System Options, then Wireless LAN and follow the prompts to enter your ssid and password. Then you want to go into "Localization" and set your Wifi Country and timezone. Then wen you exit out, it should ask you if you want to reboot. If it doesn't, just type in sudo reboot and you should be good to go.

The supplicant file is really only used if you're setting the Pi up "headless" which means no monitor or keyboard. So, you can just burn the image to the SD card, set up the supplicant file and then plug the pi in and access it through the OctoPrint web interface. But if you already have the monitor and keyboard hooked up, go the easy route.

Thanks again Ryan,
I actually meant the DOS prompt logging in to the Pi IP address.
However, I am glad to learn a bit about Linux. This is literally my second day learning as an old fart who first learned on a Commodore 64.. LOL (I am out of touch these days)
I've been into raspi-config, and performed the functions you suggest, but certainly worth another look after I've had some sleep.

I've been able to set-up OctoDash successfully (LAN connected).

I'll swap the Pi OS card out, and boot back into the Octo card and see if there's something I missed in raspi-config.

Aside from that, I can start the entire process from scratch with YouTube University running in the background. It got pretty late last night, and It's certainly possible I did something foolish without being aware.

There is no DOS prompt because the PI isn't running DOS. It's running Linux. So, take DOS and put it out of your lexicon. What you are talking about is the BASH PROMPT.

Just out of curiosity. Where exactly in the world are you located?

1 Like

I was referring to the Windows Command Prompt (that I still have stuck in my head as "DOS prompt") as an alternative to Putty to access the Pi Bash Prompt remotely through windows. Using the "ssh pi@" command.

Anyhow, you're help has been much appreciated, and I'll pop back in after digging around a little longer with your suggestions.

I'm on Ontario, Canada. :slight_smile:

Good luck!

Hi again Ryan,

I think I found the problem (or another one.. LOL).
I'm up and running, and online with the Wi-Fi connection! :smiley:
A combination of the missing " in my setup, along with the incorrect country in the "WLAN Country" under the Localisation Options. (could have been using non-compliant frequency range for Canada)

After correcting those, the "Wireless LAN" function in raspi-config finally showed the prompts I was looking for (which it wasn't before). I entered the details as you stated, and unplugged the LAN. After re-booting, I finally saw the Pi on my router.
Still can't access with "octopi.local", but easily accessed with the IP address I got from the router.

Thank you so much for your input, guidance, and suggestions.
I hope you and yours have a great holiday season.

1 Like

Do you see the ^M at the end of each line? Can't use notepad to edit the file. You have to use a Unix editor or notepad++ so you don't get that at the end of each line. Unix/linux doesn't play nice with DOS formatted files

That’s a good point to share. :+1:
I didn’t use word pad to edit, just for the copy/paste grab in the post since the screenshot looked so crappy.
Appreciate the guidance.