Pi 4B Green status light

What should the green status light be doing when trying to boot? On mine, it flashes and flickers as if there's activity for maybe 30 or so seconds, maybe a bit longer then it stops.

I've flashed twice on a kingston 16gb SD using etcher, both coming up successfully.

I've edited the supplicant file for my WiFi, but can't connect, I get a timed out when trying to access octopi.local. I've also tried direct ethernet, same result.

Unfortunately, I've no mini hdmi so I can't connect a display so I can't see what's going on.

Flashed 17 - most recent.
Pi 4B
Windows 10 machine
Ender 5 Pro printer

Wired Ethernet should work with no changes to the OctoPi image. I'd suggest leaving the printer physically disconnected until you get your RPi 4B (how much memory?) connected to your local network. Do you have access to your router's web page(s)? The DHCP server should show current leases (i.e. what machines have IP addresses assigned.)

Do you have more than one instance of Octoprint? if so have you changed the name of the first instance? out of the box it is octopi.local
As b-morgan has suggested, the DHCP server should give you a clue - but duplicate names are sure to confuse your DHCP server. I always change the name of the Octopi instance as the second thing I do after changing the Pi's password..

If the light goes off, then there's no activity and the kernel has probably 'paniced' in a heap of bits all over the carpet. Not having a micro HDMI adapter isn't helping - the Pi4 uses micro HDMI, not mini. An HDMI to micro HDMI adapter should be less than a fiver (UK £)