Pi Cam V1 on Raspberry Pi3 and Bullseye not working

Camera model

Pi Cam V1

What is the problem?

For the life of me, I cannot get my pi cam V1 (which was running perfectly with the old system using mjpgstreamer) running properly with this new Libcamera system. I had to fight quite a bit to find why on Earth there was a hardcoded YUYV format that could not be changed for Libcamera and still, the video displays shortly in Octoprint with purple flickers then stops streaming after 1 minute or so. All documentations related to the pi cam v1 talk about rpicam-apps that are no longer supported nor even provided in Raspian packages... One day of fight for a camera, it is not solved and the Github thread has been closed...

What did you already try to solve it?

Spent the whole day trying to figure how the new system was working and changed multiple time the configuration of Libcamera.conf, especially the video format. Changed default dtoverlay in config.txt to match current camera.

Have you tried running in safe mode?


Did running in safe mode solve the problem?

No, plugins are disabled in safe mode

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)
octoprint-systeminfo-20231213231513.zip (51.8 KB)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Raspberry Pi 3 with:
PRETTY_NAME="Raspbian GNU/Linux 11 (bullseye)"
NAME="Raspbian GNU/Linux"
VERSION="11 (bullseye)"

Octoprint 1.9.3
Browser: Safari 17.1.2
OS: Mac OS 14.1.2

$libcamera-hello --list-cameras
Available cameras
0 : ov5647 [2592x1944] (/base/soc/i2c0mux/i2c@1/ov5647@36)
    Modes: 'SGBRG10_CSI2P' : 640x480 [58.92 fps - (16, 0)/2560x1920 crop]
                             1296x972 [43.25 fps - (0, 0)/2592x1944 crop]
                             1920x1080 [30.62 fps - (348, 434)/1928x1080 crop]
                             2592x1944 [15.63 fps - (0, 0)/2592x1944 crop]

I'm a bit confused, as it looks like you aren't using OctoPi, but installing everything manually - or at least that's where the systeminfo bundle is from. Could you provide a bit more detail on which streaming service you've installed and how you've set that up? You've mentioned configuring a 'libcamera.conf' file, which is something normally found in OctoPi - so unless some other software is using the same named config files, wires have been crossed somewhere.

1 Like

For 7 years now, I have been using a Raspberry Pi 3 with Raspbian installed from Raspberry Pi official website, I also installed Octoprint manually following the official documentation and for the pi cam V1 camera, I followed official instruction in the Octorpint community to get it streaming perfectly fine, I even wrote an article about running a Pi cam and an USB camera with a custom script running Mjpgstreamer. Everything was smooth and running until the last Octoprint update which got rid of lots of useful stuffs when running an old Raspberry Pi and an upgrade of the system too that removed working stuffs. I noticed that the LED of my Pi cam was not lit anymore, so, I did some research and I even bought a replacement but the LED does not lit up on both cameras, rpicam-apps are not installed on my system for some reason and cannot be installed via apt, so I used what was installed by default: libcamera, I could take a photo with both cameras but the color was weirdly purple, I tried different settings in libcamera to see a direct video streaming but the streaming stops by itself after less than a 1 minute or so while flickering a purple color randomly when streaming. Something has been broken in my system and the camera seems to not work properly anymore. All connections have been double checked multiple times. I strolled internet for a day without finding anything worthwhile about pi cam v1 and Raspbian bullseye in 2023.

Octoprint updates don't mess with the raspbian system files. You must have done sudo apt update and sudo apt upgrade. That updates, removes and replaces system files.

Well... I feel a little ashamed, I switched the long ribbon cable to a shorter one and both cameras are performing well except that the front LED does not switch on for some reason.
Upon inspection the ribbon cable I was using for years had been badly creased.

Regarding the updates, they are necessary if you want to keep your system secure.