pi cam v2.1 on PI4 mod B no stream in OctoPrint

Camera model

PI cam 2.1

What is the problem?

can take picture with "raspistill -v -o Try.jpg" but get no stream in OctoPrint
stream http://192.168.xx.yyy/?action=stream
libcamera-hello --list-cameras says "no camera"!?

What did you already try to solve it?

activated legacy camera support

Have you tried running in safe mode?

yes - no change

Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)


Additional information about your setup

using OctoPi 1.0.0 and OctoPrint 1.9.3 - new camera stack


Sorry, forgot systeminfo
octoprint-systeminfo-20231120202003.zip (53.2 KB)

It.s really annoying ...
... after several hours I found a post What are the default webcam URLs in OctoPrint on OctoPi? that The default webcam URLs in OctoPrint on OctoPi are:

  • Stream URL: /webcam/?action=stream (no leading http, it's a relative path, it's correct this way!)
  • Snapshot URL: http://localhost:8080/?action=snapshot

Why is "webcam" missing in the latest default installation URL?
Now stream works, but snapshot ist still faulty.

... but streams only works with an old Logitech webcam - PI camera still not working.

After a day of investigations I switched to "normal" OCTOPI and now everything works fine out of the box with PI cam 2 and legacy LOGITECH webcam.

1 Like

Nice, but why are you shouting?

My Raspberry Pi Camera V2.1 works fine (snapshots and streams) with OctoPi (new camera stack) on my Raspberry Pi 3B. My Raspberry Pi Camera V3 works fine on my Raspberry Pi 4B with the same OctoPi (new camera stack) image.

Can you be more specific about "switched to normal" ? I just can't get this thing figured out. What do I do for a normal Pi cam on a Pi4?

Hi Gary,
With normal I mean the OCTOPI SW version without the option „new camera stack“. My camera is an old V2.1 have a look at: Raspberry Pi Documentation - Camera