Pi cam V2 won't display in octoprint

Camera model

Pi Cam V2

What is the problem?

Camera feed won't display in octoprint

What did you already try to solve it?

Checked ribbon cable at both ends( shut off pi, unplugged and replugged cable with metal touching pins)
Rebooted octoprint (several times after different changes)
Enabled camera feed through raspi.config
sudo apt update
sudo apt upgrade
Changed aspect ratio in settings
Clean install of octopi onto my RP4

I'm not super tech savy, I only knew to get into the rasp.config using putty due to another post in the forum, none of the 3 fixes suggested there worked unfortunately. If I can't get it working I'll probably return the camera which is a bummer.

Hello @forster46 !

Have you setup OctoPrint's Webcam settings to the correct addresses?

And please:

When you create a new thread and there is a template, do not delete it. Respond to the questions and if it asked for: Provide the systeminfo bundle.

How would I go about doing that? Is there an easy way to check that the camera is even detected?
octoprint-systeminfo-20240206100057.zip (17.7 KB)

./mjpg_streamer -o output_http.so -w ./www-octopi -n --listen -i input_uvc.so -r 640x480 -f 10 -d /dev/video0

Your camera is being detected and you are using the old camera stack.
(IMHO the new camera stack works better.)

That said the stream is only being published to the loopback address and I'll bet that you have not yet set up haproxy.cfg to allow access to the camera.

I believe you must do so manually.

I have the same issue after updating to 1.10rc1. The camera worked before.

octoprint-systeminfo-20240207161553.zip (83.2 KB)

Is there a write up anywhere that can walk me through how to do that? When it comes to doing anything in the terminal I am pretty limited on knowledge.

If you are going to stick to the old image

See: https://community.octoprint.org/t/setting-up-multiple-webcams-in-octopi-the-right-way/32669

However skip down to the haproxy section.

You are better off moving to the new image but not restoring from a backup as that will attempt to use the camera configuration for your old installation.

It is a bit ridiculous this whole camera change. Even "tech savy" people seem frustrated by the inconsistencies and issues. I myself have tried many things and can no longer get any of my pi-cams ardu cames or even usb cameras to work.

Yeah, I'm going to try a clean install of octopi with the new camera stack and if that doesn't fix the issue I'm just going to return the pi cam while I still can. Kind of a bummer

Tried that - no luck for me. Hopefully your results are better.

Hi All

Same issue here tonight after an apt-update. Found this however which could be a fix