Pi Camera Module 3 - Raspberry Pi 5: how to make it work?

Camera model

Pi Camera Module 3

What is the problem?

mjpg-streamer does not install on Bookworm 64-bit (latest release)

What did you already try to solve it?

Today I received the adapter cable to connect my PiCamera to the raspberry PI5 (which has the latest 64-bit bookworm release installed).
Using the command "libcamera-hello -camera 0 -t 0" I verified its correct functioning, but now I would like to use it with mjpg-streamer to be used with Octoprint, in order to monitor the progress of my 3D prints.
By following the normal instructions found online (for example this one Setting up OctoPrint on a Raspberry Pi running Raspberry Pi OS (Debian)) I can't finish compiling mjpg-streamer and therefore can't use it.
Alternatively I could also use ustreamer (GitHub - pikvm/ustreamer: µStreamer - Lightweight and fast MJPEG-HTTP streamer) which runs without problems but cannot connect to the PiCamera.

Are there other solutions that allow me to continuously stream through the PiCamera on Raspberry Pi 5?

EDIT: I see that I should use camera-streamer, is there any tutorial to install in an existing installation of octoprint? Whithout using the custom image? (My raspberry Pi does not only manage my 3d printer...)

Hello! Here is another user with the same problem, I have been using my Raspberry Pi 4 so far with the v3 camera module without problems, but now I have switched to the Raspberry Pi 5 and I have tried with the 3 streamers and it does not work.

I have isolated because they don't detect the correct route: -camera-path=/base/soc/i2c0mux/i2c@1/imx708@1a

That's the one that uses camera-streamer but doesn't detect anything so it doesn't get to run.

Let's see if anyone has any ideas or has managed to get it to work with a streamer.

Hi there. Yeh im in the same boat. Camera-streamer also not working for me onn pi5. Tried the manual and package installs, neither worked for me but here's the link in case you can get it right. Let us know... Camera module 3, Raspberry Pi OS Desktop, Raspberry Pi 5 · Issue #128 · ayufan/camera-streamer · GitHub

Same here, cam is working when rpicam-apps are used, streaming thru rpicam-vid is fine, but the same problem with octoprint functionality

I found a solution, not yet perfectly suitable for Octoprint but I'm sure it will be, which streams the RaspiCam V3 (but not only that, USB webcams are also supported) on Raspberry PI 5, find all the info here: https: //github.com/signag/raspi-cam-srv

For now, streaming without authentication is not yet supported but I'm sure the developer will do it in the future!

Edit: the athor allowed the anonymous streams so this is the real solution for our issue! I'd like to send a donation to him, please do the same :wink: