Pi does not react to ender 3 being plugged in

What is the problem?

When connecting my ender 3 to my Pi 4, dmesg gets no additional logs at all.

What did you already try to solve it?

Tried different ports on the pi and different usb cables, and used a known working device to confirm the port works.

Have you tried running in safe mode?

Yes

Did running in safe mode solve the problem?

No

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

octoprint-systeminfo-20220713050742.zip (27.5 KB)

Additional information about your setup

Octoprint 1.8.1
Version 0.18.0, running on Raspberry Pi 4 Model B Rev 1.1
Fresh install of octoprint, using the imaging tool
New ender 3 pro

Hello @adamsogm !

How many cables did you try?
There are some points to distinguish data cables from a power cables:

  • Data cables usually a re thicker than power cables
  • Good data cables have ferrite beads at the ends

It appears that all 3 cables I tried were power cables. After your comment I managed to pull a cable that works from the depths of my cable bin, thanks for the help.

1 Like