Pi refuses to connect to wireless net work with DCHP

OK- I've spent 2 days trying to get the pi to connect to my network and am about to throw it over the garden wall...! Previously I had this running on the same network without issue.

've downloaded Octoprint via the raspbery pi imager and configured the wireless lan to my SSID and password. I flash the pi and watch the install through, which happens without failure. At the end, there is no message to say a connection is available through octopi.local nor is there any ip address.

I run raspi-config and set the wifi up in the menu there- no change.

With my very limited linux knowledge I can see the hostname -i is and is not on my 192.168.... network and a ping command results in "temporary failure in name resolution"

Any thoughts would be appreciated!

thats strange my pi went offline for a few hours while i was printing something the other day i had to reboot it to get it to connect .

you can manually enter it after the wifi info after the fact, thats what i had to do a while back, you have to image the sd card then read it with notepad++ and you can edit it there

OK- tried 2 different approaches- I have edited /etc/wpa_supplicant/wpa_supplicant.conf to include the wifi info, reboot- nothing.
Also I have gone onto the sd card on my pc and edited octopi-wpa-supplicant.txt with the same info- again nothing...

Anyone else got any ideas?

Try working through the troubleshooting shown here:

Not a solution, just an FYI: hostname -i will always return the internal "localhost" address, ie always, not the address used on the external network. To get the actual network address, you need to use hostname --all-ip-addresses or hostname -I.