Pi will not see my printer - PC will

What is the problem?

My pi does not see my printer as a usb device...or at all.

It worked fine initially, many months ago. I had it plugged in, octoprint was running fine.
When I ran the lsusb command on the pi via ssh I could see my printer in the list (QUinheng something semiconductor or something).
Then one day...coincidentally after updating octoprint...it just didn't anymore.
I fought for weeks with fresh installs, multiple cables, etc etc. It would randomly show up in the list here and there but I could not seem to ever recreate the scenario for when it did or didn't.
Anyways here I am trying again.

What did you already try to solve it?

Fresh install of raspbian buster lite (just to check the lsusb command and it still does not see it)
Fresh install of octoprint again

My cable is modified for just data lines no B+. I'll have to track down another cable to see if its the missing 5v thats messing with things...don't have anymore on hand at the moment
I can plug into my PC with the same USB cable and connect just fine. I just used the stock creality software and was able to flash new firmware from the PC so I know the cable is fine and the connection to the printer is fine

But the pi and subsequently octoprint still will not see it.

I can unplug usb from computer and then plug usb into already running pi. Run the lsusb command via ssh, and it is not there in the list, then I can unplug from the pi and back into the computer and it pops up and I can connect again with the slicer.

Complete Logs

Additional information about your setup

Latest octoprint version.
Raspberry pi 3 B+
Creality CR10-V2 printer. Factory firmware initially....literally just upgraded during troubleshooting and still no change
Pi is LAN hardwired

You sure you taped the + and not ground? I did that and it wouldn't see the printer.


I've got the power and ground removed from the usb. Its just the two data lines. It worked with this configuration in the past so I have no reason to question it. Beginning to question everything now

Try with ground uninsulated. The ground is essential for proper communication.


The ground is a necessity. Not sure why it would have worked before, but the ground is a reference for the data signals, a shield from external interference, and protection for the pi and the external connected printer. If you somehow were to have stray voltage on the printer it could take out the Pi's USB ports and the printers USB port

1 Like
  1. The CR10 V2 backpowers, but it doesn't care - it still works. (I'm running one V2.5.2 board at the moment by just plugging it into my PC. It's a spare, not in any printer.)

  2. I've noticed that if I'm running Cura, I can't connect to a Pi that's running OctoPrint. Strange, that shouldn't ever happen, but until I found that out, I thought all my printer mainboards were defective. (I leave Cura running, even if I'm not going to print anything. It's maddening to run a fast computer, and having to wait for a program to load up. And I have more than enough RAM that 330MB doesn't bother me.)