Pi Zero 2 won't connect to printer, but Pi 4 will, why?

What is the problem?

I have been running OctoPrint on a Pi Zero 2 for months, no complaints. Today I was cleaning my printer, after when I plugged the pi back in, it could not detect the printer. The pi still powers on and connects to the internet, but octoprint cannot detect my printer, tried multiple times. I then flashed a new copy of OctoPrint onto a Pi 4 and strangely it works perfectly fine and connects to my printer. Anyone know what's going on? I use a Creality Ender 3 v2.

What did you already try to solve it?
Tried swapping out cables. The pi Zero 2 connects from it's micro USB port. I don't have a male to male micro usb cable so I use two cables instead, a male mico usb to female usb from the pi, then a male usb to male micro usb to the printer. I tried multiple different cables. The pi 4 connects with one wire, USB to micro USB.

Have you tried running in safe mode?
Yes

Did running in safe mode solve the problem?
No

Did you use the correct usb port on the Pi Zero?
As you can see on this picture, the right port is power only and can't establish any usb connections

Yes, it is powered on and connects to the internet. Octoprint loads, it just can't connect to the printer. Had been working fine for several months before this.

@PrintedWeezl 's was asking, that you not have accidentality swapped the plugs for the USB-micro B sockets.
Both can accept power, but only one can connect to your printer.

1 Like

Sorry, I misunderstood. But yes the plugs are plugged in correctly, still getting the "No serial port found" message.