Pi4 stopped responding to ssh pi@octopi.local

What is the problem?

I had been using my pi4 & Octoprint for about a week with no issues whatsoever. I went thru the step-by-step process of downloading 2020-12-02-octopi-buster-armhf-lite-0.18.0, flashing the image to a blank 16g microSD card, booted my pi from the card, ssh'd into it with ssh pi@octopi.local, etc. and was running along just fine. Sending prints to my Ender 3 pro via OctoPrint with no issues at all. Life was good. 3 days ago, I came back to my PC and tried to run OctoPrint from my web browser (just as I had been doing all along) and I got the error, "This site can't be reached..." So I tried again, with the same results. So I decided to try to ssh to the pi via the command prompt (windows 10 user here) and started getting the returned message, "ssh: Could not resolve hostname octopi.local: No such host is known." I HAD NOT CHANGED ONE THING IN MY PROCESS. This just started happening out of the blue. I tried flashing a new boot SD card, same results. I am at a complete loss.

Using command prompt, no safe mode, trying to SSH into Octopi:
C:>ssh pi@octopi.local
ssh: Could not resolve hostname octopi.local: No such host is known.

Safe mode at command prompt:
C:>ssh pi@octopi.local
ssh: Could not resolve hostname octopi.local: A non-recoverable error occurred during a database lookup.

What did you already try to solve it?

I tried the entire process from scratch and reflashed a new boot SD. I even went so far as to purchase a new Pi4, and got the same results.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)

I apologize; I do not understand what goes here. I am new to this.

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

OctoPi version: 0.18.0
Printer: Creality Ender 3 Pro
Firmware: Marlin TH3D UFW 2.22
Browser: Google Chrome
OS: Windows 10

Hello @TRYoung71 !

Have you already tried the IP address of the Pi?

Also, when routers get updates over night, they can lose some information.

When the hostname can not be resolved, it's not OtoPi/OctoPrints fault. It's either the router or sometimes - in this case - Windows.
You may have a look at the routes informations if the Pi is listed there.

"Could not resolve" says that the computer can't translate octopi.local into the IP address (which is what the computer uses). Connect to the IP address and it should work.

1 Like

Connecting via the IP address did the trick. Thanks to you both for helping out a newbie!

1 Like