Pi5 - bookworm - how's it going?

RaspberryPi 5 and Bookworm

About to embark on seeing if it works, so pre-checks for info here and any gotchas before I can play later today.

So I have a Pi5 and that needs Bookworm, I can't see much problem with the Pi itself as the OS does that job.

Has there been any Pi5 alpha or beta (RaspberryPi's bookworm/Pi5 point of view) testers have a go.

If so does it work.

What might be a problem. I would guess most would be bookworm problems if anything.
Python3.11, was that fixed?
Dual camera?

It's way over powered for this job ;-)?

As a side does OctoPi have any test images also?

You might try using octoprint_deploy to install OctoPrint on the Bookworm OS. It worked for me on my Orange Pi 3B which is running Bookworm.

1 Like

The only thing I've seen mentioned specifically is an issue with pydantic versions. Even after the 1.9.3 update to fix that for bullseye I think bookworm needed a slightly older version than that.

No not yet. I'll start testing as soon as I get my Pi 5 - which will be around the end of October :tentacle:

I installed Octoprint with Octoprint_deploy this weekend on a fresh install of bookworm.
Had zero issues with the install, and no issues with operation so far. This was on a Pi4. Pi5 shouldn't have any issues. Octoprint runs in Python, so the underlying interpreter still sees all the GPIO as it should, Etc..

1 Like

There are now OctoPi nightly builds you can test and report if they are any good


I per-ordered a Pi5 here. But I have no idea when it will arrive.

Priority were delivered yesterday, so first to order will be soon.
So PiHUT UK for anyone using magpi/HackSpace codes have them now.

Pi5 documentation should be on Monday, at least that's what I was told on Friday.

Hopefully someone makes a plugin to read the voltages (and some current), which will be good to check for a good 5V input.

Dual camera for monitoring should be easier now OctoPi has put the effort in to move over. At least if you don't use a display though USB are on separate lanes now.

I didn't get the time to try the first deploy method, but will give OctoPi nightlies a go first as that's what people tend to use (I think?) on a Pi.

Also Pi Imager (v1.8) has been updated, so you might want to check the alterations for saying what works on what Pi. So Pi1/2 series don't get offered 64bit and probably recommend 64bit for Pi4&5.

there is no nightly bookworm build. Just the MD5 file.

Attempted the latest arm64 bookworm nightly (11/5) on a pi 5 and the OS boots, but Octoprint Server won't start. Patiently awaiting Pi 5 support.

Installed 2023-12-05_2023-10-10-octopi-bookworm-arm64-lite-1.1.0.zip on a Pi5
and it is working so far.

I am also running 2023-12-05_2023-10-10-octopi-bookworm-arm64-lite-1.1.0.zip on my Pi 5. Seems to be fairly stable. Only issue i am having is i cant get the camera resolution to change. It seems to be stuck on 640x480.

I used last night's nightly and the octoprint service still wouldn't start. Went back to 12/5 and everything seems great and am 5 hours into an 8 hr print. Love how quick it is compared to my old pi3

Just saying hi to all the new posters with Pi5's

1 Like

Long time user on a old windows machine, finally bit the bullet and got a Pi. Made more sense to me to try out the 5 since the price is very similar to what i can find for a 4. Hopefully i can be of some help trying new versions in the future.

I can't get the camera resolution to be anything other than 640x480. I've got a Logitech C270 HD.

Has anyone got camera resolution changing to work?

Hello! I would love to hear the answer to this as well. I can't get my camera resolution to anything other than 640x480. I tried everything that I found on the web but nothing worked. I'm stuck with low-quality time-lapses which was the only reason I got a Raspberry Pi.

Please help!

Hi! Thanks for sharing this. I read through everything. I install through octoprint_deploy, which worked great. The only problem is the crappy camera resolution.

Which command do I need to do to get full resolution?

if you used octoprint_deploy to setup the camera stream I believe the resolution is controlled through environment files. I believe those are saved as /etc/cam_instance.env or something like that. I recommend reaching out or searching the octoprint_deploy discord server.

I've tried flashing a few of the nightly builds and I keep the "getting server not running" issue. Maybe I'm missing something.