PiOS boots just fine...CANNOT get Octopi to boot

No matter what version of Raspberry Pi OS I choose, it boots up perfectly. No matter what version of Octopi I try to boot, I am unsuccessful.

I have tried using the Pi Imager (with and without "control-shift-X". I have tried different SD cards. I have tried installing manually (unzip file and put onto card, manually changing the code, etc.). Each time I try to boot Octopi, the green light on the Pi looks normal (like it's active)...then after a minute or two, it does one, short flash every 10s(?), or so.

I have not tried running in safe mode (apparently, I don't know how)...but I don't see how this would be relevant when the regular OS boots up just fine.

I'm running a brand-new Pi 4, with 4gb of ram. Using the CanaKit USB-C power supply.

Getting pretty darn frustrated, as Octopi is the only reason I got the Pi, in the first place.

Brand new Pi 4 likely means with older images you would get unsupported board (4 short 4 long flashes) but it sounds like that doesn't happen - and since last week the image available from the RPi Imager & octoprint.org was updated.

It sounds like maybe it is not connecting to the network? I can't remember the 10secs flash meaning anything in particular after the boot sequence.

Or do you have it connected up to a monitor over HDMI? Usually that's the best way to troubleshoot boot issues, as you get direct access to the Pi and the command line.

Don't worry about safe mode - yes that assumes it boots up the OS fine...

I have, indeed, connected to hdmi (got the little 4" touchscreen)...both on the small touchscreen and a regular monitor. If it's having difficulty connecting to the network, wouldn't that happen when I install the regular OS, as well?

And in regard to the green light, when it goes into "I'm not really doing anything, but I keep the green light flashing once in a while, so you think there IS something going on" mode...it does not flash at regular intervals. Very sporadic.

Are you sure you are installing the Octopi OS?
Run Pi Imager > Choose OS > Other Specific Purpose OS > Octopi
You have to scroll down for "Other Specific Purpose OS" to click on it.
Also make sure your SD card is formatted to FAT32.
Check your router after to see if it has your Octopi listed. If it doesn't you may want to go into your raspi-config and confirm your SSID and password.

I wish it were that simple. I'm doing all those things. I'll try checking the router - haven't done that yet! Thanks!

Having the same issue here. I had managed to get OctoPrint working but wasn't able to connect VIA SSH so i redid the image to the same SD card but it wouldn't boot and the "act" light never Flickered. Since then I tried creating the image on different computers and on different SD cards (including overwritting the card that was currently running an old Despian Verison) Still not working!?? not getting any "Act"


Try to connect the Pi to a HDMI TV/monitor to see if there is any action at all.
Usually, at the end of the startup sequence - and if you use WiFi with the correct credentials - there should be an IP address provided

If there comes nothing, the Pi may be broken...

Well seems must have been a combo of SD card imager not being "overwriting correctly" seems when i did a "disk manager " delete partition and create partition" it worked . and fyi the "Act" light never flickered even though the octoprint booted without problem with access to SSH and to Browser :slight_smile: now if i could only understand why OctoPrint doesn't recognize the printers "SD" card? I'll do a search for topics in the community on that..

This is already a new topic, but you may look here:

I said I was going to look on the community for the issue. I guess i should have closed this topic but I really dont see how/where to do that.... Sorry NEWBIE

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.