Pip 19.0.3 NOT installing?


#1

So on using this Line to update ;

~/oprint/bin/pip install https://get.octoprint.org/latest

I get this message at the end of it;

You are using pip version 19.0.1, however version 19.0.3 is available.

You should consider upgrading via the 'pip install --upgrade pip' command.

HOWEVER - this is what happens when attempting to remedy error message ??

pip install --upgrade pip

-bash: pip: command not found


#2

pip is located in /home/pi/oprint/bin which is not a part of the default $PATH.
Just go to /home/pi/oprint/bin and type:

sudo ./pip install --upgrade pip


#3

Uh, no.

OctoPrint itself manages the pip version. You are encouraged to leave it alone.


#4

thanks - thats worked !!


#5

I do understand that - BUT as Octoprint did NOT 'work out of the box' for me I had to do what I could do make it work - it now works 80 %


#6

Personally, I have never typed that line into a Terminal ever and I've used OctoPrint for over a year now. The bundled Software Update plugin has always worked for me.

If you're working on a fork of OctoPrint, I can see running that possibly against your own clone of your own fork. Or if you're developing OctoPrint with the authors and you need to follow a particular branch they're working on for testing, I can see doing that.

In rare cases when leftover eggs are lying around then pip install --force-reinstall https://get.octoprint.org/latest (having activated the virtual environment first) would be in order.

And yet, this isn't really the normal usage case. I don't believe that it's a good idea to run pip with sudo, for what it's worth but I'm really not the expert here. I just know that foosel herself mentioned this before.


Why not describe what the problem was before you began trying to fix it?


Upgrade pip manually?
#7

Thanks for your reply, installation is now all OK - the only thing NOT working is the Raspicam streaming. All I get is the ‘Webcam stream loading’ forever BUT will test with a USB webcam when I get one. Just haven’t had time of late so will report back soon as I’ve tried a different camera option


#8

You might want to mention your browser. I know that the IE browser isn't happy with the <img /> tag approach that OctoPrint uses.


#9

Thanks - looks like my RaspiCam is dead (unless I messed settings up)- Logitech C270 USB worked straight away