PIP wont install

What is the problem?

I am having this issue when I want to install a plugin:
The pip command could not be found or does not work correctly for this installation of OctoPrint - please consult the log file for details and if necessary configure it manually. No installation and uninstallation of plugin packages is possible while pip is unavailable.

What did you already try to solve it?

I tried to give it the update/install command but nothing happened
I tried clicking the Force the use of the --user flag with pip install

Have you tried running in safe mode?

Yes, same error

Did running in safe mode solve the problem?

No

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)
octoprint-systeminfo-20240129223751.zip (264.7 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Ocotoprint Version 1.9.3, Build 2023.10.09.154319, based on OctoPi 1.0.0, running on Raspberry Pi 3 Model B Rev 1.2, Printer: Ender 3 V3 SE

You're running using OctoPi on a Raspberry Pi, but it looks like your server is configured for the below pip command, which is completely wrong since it's for windows!

2024-01-29 22:23:35,839 - sarge - WARNING - No process found for Command('C:\\OctoPrint\\WPy64-31050\\python-3.10.5.amd64\\Scripts\\pip.exe --version')

Did you perhaps restore a backup from Windows -> OctoPi? Where this could have been manually configured before, and it should now be left to default (autodetecting pip is very reliable on OctoPi).

I would try and clear any command like this from the Plugin Manager & Software Update plugin settings.

1 Like

Actually yes, I made a back up from windows
Looks like that is the problem
So I just make a new installation and that should work right?