PiTFT Plus 480x320 3.5" TFT+Touchscreen

What is the problem?strong text

PiTFT Plus 480x320 3.5" TFT+Touchscreen

What did you already try to solve it?

WRITE HERE

Have you tried running in safe mode?

No

Did running in safe mode solve the problem?

WRITE HERE

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

WRITE HERE

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

WRITE HERE
I am trying to get the touchscreen working with a Pi 4 but keep getting errors.
I am following this setup (https://www.printables.com/model/6153-mk3-rpi-pitft-cover) But when i put in sudo /home/pi/scripts/install-desktop I get an error command not found.
And this one (sudo mv /usr/share/X11/xorg.conf.d/40-libinput.conf ~/) No file found I dont no if linked to the first one.

Thanks For any Help

organic

Unfortunately that guide is a bit older and doesn't work anymore with current images.

You could try it with an older image, but be aware that the extended support for the underlying OS runs out in June.
It does of course still work, but there won't be any security updates in the future.

Here's the old image which was probably used for the guide

https://github.com/guysoft/OctoPi/releases/download/0.18.0/octopi-buster-armhf-lite-0.18.0.zip

Thanks for that but still no luck.
I might have to go down a different rout.
I now have a pi4 with same screen but its just white and not working.
I don't suppose you have any links for a pi 4 and Adafruit 3.5 TFT and octoprint?

Just one problem I am leaving for work and not be back for 3 weeks and not be able to reply.

Thanks again.

You didn't provide us with important details like what image did you install on your RPi 4?

/home/pi/scripts/install-desktop exists on my OctoPi 0.18.0 system (RPi 3B) and my OctoPi 1.0.0 (RPi 4B) system. I've used it on both systems. If you got an error on this step then I don't expect anything after that to work regardless of the age of the guide.

I suggest that you start with a fresh microSD card and flash an official Raspberry Pi OS (32-bit) image. In my experience, Adafruit has very good instructions for their products so use their resources to get the display working.

If it doesn't work, then it might be worthwhile to use either the Adafruit forums or the Raspberry Pi forums for help it getting it resolved.

If everything is working now you could try again with an OctoPi image or you could install OctoPrint using octoprint_deploy.

I'm not sure where the guide will go wrong but maybe @PrintedWeezl can provide more details after you tell us exactly which step fails for you.

1 Like