Plugin Error "Invalid group name '}gin'"

What is the problem?


I tried to activate the slicer plugin that was installed on my octopi server ; immediately after, octopi restarted, all my plugins / setups disappeared and I cannot install anything anymore.

Plugins I have on my octopi: at least octoeverywhere, calibration tools + a few other I cannot remember as of now.

I got the error

2024-05-09 09:23:49,331 ! Traceback (most recent call last):
2024-05-09 09:23:49,332 ! File "<string>", line 1, in <module>
2024-05-09 09:23:49,332 ! File "/tmp/pip-req-build-z_kgw25b/", line 110, in <module>
2024-05-09 09:23:49,333 ! setup(**setup_parameters)
2024-05-09 09:23:49,334 ! File "/home/pi/oprint/lib/python3.7/site-packages/setuptools/", line 152, in setup
2024-05-09 09:23:49,335 ! _install_setup_requires(attrs)
2024-05-09 09:23:49,336 ! File "/home/pi/oprint/lib/python3.7/site-packages/setuptools/", line 142, in _install_setup_requires
2024-05-09 09:23:49,337 ! dist = MinimalDistribution(attrs)
2024-05-09 09:23:49,338 ! File "/home/pi/oprint/lib/python3.7/site-packages/setuptools/", line 134, in __init__
2024-05-09 09:23:49,339 ! distutils.core.Distribution.__init__(self, filtered)
2024-05-09 09:23:49,340 ! File "/home/pi/oprint/lib/python3.7/site-packages/setuptools/", line 421, in __init__
2024-05-09 09:23:49,341 ! for ep in pkg_resources.iter_entry_points('distutils.setup_keywords'):
2024-05-09 09:23:49,341 ! File "/home/pi/oprint/lib/python3.7/site-packages/pkg_resources/", line 656, in <genexpr>
2024-05-09 09:23:49,342 ! for entry in dist.get_entry_map(group).values()
2024-05-09 09:23:49,343 ! File "/home/pi/oprint/lib/python3.7/site-packages/pkg_resources/", line 2802, in get_entry_map
2024-05-09 09:23:49,344 ! self._get_metadata('entry_points.txt'), self
2024-05-09 09:23:49,345 ! File "/home/pi/oprint/lib/python3.7/site-packages/pkg_resources/", line 2504, in parse_map
2024-05-09 09:23:49,346 ! maps[group] = cls.parse_group(group, lines, dist)
2024-05-09 09:23:49,347 ! File "/home/pi/oprint/lib/python3.7/site-packages/pkg_resources/", line 2479, in parse_group
2024-05-09 09:23:49,348 ! raise ValueError("Invalid group name", group)
2024-05-09 09:23:49,348 ! ValueError: ('Invalid group name', '}gin')

What did you already try to solve it?

I tried to find the faulty file containing the string '}gin' which sounds suspicious

This is ./oprint/lib/python3.7/site-packages/OctoPrint_PiSupport-2023.10.10.dist-info/entry_points.txt which contains

pi_suptort = octoprint_pi_support

It looks like this file has been corrupted ; I tried to "fix" it but it did not help (just now I have different errors while trying to install any extension and I did not recover my previous extensions)

I just get different error messages now

Could not parse output from pip, see plugin_pluginmanager_console.log for generated output

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle (55.6 KB)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible


Yeah that looks like corruption.
If I were you I would start over on a fresh SD card.

You can try to backup you current instance via the backup and restore menu in the webui - but those files could also be corrupted.

Thanks! Not sure what caused this part ; not sure as well if the fact that my raspberry pi is a bit old could be related to this ?

IMO Either the SD card is failing - maybe from old age or there was file system corruption which could be caused by under voltage or pulling the plug without shutting the pi down

Hum I had voltage issue a few month ago but since then the octoprint server was really robust and always available for printing ; I can try re-image the current card and order a new one just in case if it happens again)

Sure you can try that

Good luck :crossed_fingers: :tentacle: