Plugin Fails to Install Octoprint-Wyze (cffi module)

From what I can tell from the Octoprint-Wyze install log, the cffi module fails to build when gcc is not found. Otherwise, the log shows a successful completion, but after restarting Octoprint (ver 1.9.3) the plugin is not installed.

Building wheel for cffi (pyproject.toml): started
Building wheel for cffi (pyproject.toml): finished with status 'error'
error: subprocess-exited-with-error
Γ— Building wheel for cffi (pyproject.toml) did not run successfully.
? exit code: 1
??> [62 lines of output]
No working compiler found, or bogus compiler options passed to
the compiler from Python's standard "distutils" module. See
the error messages above. Likely, the problem is not related
to CFFI but generic to the of any Python package that
tries to compile C code. (Hints: on OS/X 10.8, for errors about
-mno-fused-madd see clang error: unknown argument: '-mno-fused-madd' (python package installation failure) - Stack Overflow
Otherwise, see CompLangPython - Python Wiki or
the IRC channel #python on
Blockquote (251.9 KB) (1.7 MB)

I'm running Octoprint on an Android Pixel 3XL, Android ver. 13 (using octo4a).

Does anyone have insight on how I can get this plugin installed correctly?

Thank You,

I did a Google search for "octo4a gcc" and found numerous references that might be helpful.

Brad, Thank you very much for your help. I did set up plugin extras on Octo4a, and this time the install of octoprint-wyze found the gcc compiler. However, in building the dependency cffi it seems to have failed:

Package libffi was not found in the pkg-config search path.
Perhaps you should add the directory containing `libffi.pc'
to the PKG_CONFIG_PATH environment variable.

Now I am stuck with this missing dependency.
After Googling libffi-dev for Alpine Linux, I found this command to work:
$ apk add libffi-dev

Now installing Octoprint-Wyze gets farther along, but still issues errors for missing dependencies or ones in conflict. I found issues with libffi-dev, but they may not matter.

Then I installed Octoprint-Wyze one more time and it worked!:

That worked, and now Octoprint-Wyze installs and runs!


Thank you for your help getting me onto this road to success!!!