Plugin manager installs "unknown" plugin

What is the problem?

Installing a plugin in plugin manager causes the info message to say that it installed unknown. Rebooting doesn't show any sign that the plugin is working, especially checking under the plugins tab where the plugin is no where to be found.

What did you already try to solve it?

Tried to run in safe mode, didn't work, tried to upload from file, installed but didn't work, tried URL, installed but didn't work, so same outcome every time.

Have you tried running in safe mode?


Did running in safe mode solve the problem?

No, but I noticed that the info message showed the name now, aka octorelay, but the plugin still did not work.

Systeminfo Bundle (1.8 MB)

Addinal information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Ender 3 V2, raspberry pi 3 b+

Seems like the plugin stopped working with OctoPrint 1.8.7 and this issue was reported before.
Something is wrong with the RPi.GPIO python module, or the way the plugin uses it.

I would suggest you try the PSU Control plugin instead.

Found a post that seemed to indicate that this may be a RPi.GPIO version issue. If you run the following command in an SSH connection to your pi what is returned for version?

source ~/oprint/bin/activate
pip freeze | grep RPi.GPIO

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.