Plugin not showing up after installation

What is the problem?

We have a Leapfrog Bolt Pro printer. It had a factory default UI. I reinstalled it with OctoPrint.
After that the RGBW led stip didn't work. I found the rgbStatus plugin on Leapfrog's GitHub.
I had some errors when I tried to install, but I fixed those.
As you can see on the image above, I can install the plugin now.
But after installing the plugin and restarting, it is not showing up at the plugins.

What did you already try to solve it?

Tried to reinstall the plugin. Tried installing in safe mode.Tried rebooting the system.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!) (358.3 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Linux octopi 5.10.103-v7+
OctoPi: v0.18.0
OctoPrint: v1.8.1
Raspberry Pi3

The plugin you have linked has not been updated in over 5 years, so it simply isn't compatible with modern OctoPrint & Python 3.

1 Like

Without knowing anything about python, could I somehow upgrade this plugin so it would work?
I can't find any other plugin that is compatible with TLC5947 board.

You would have to migrate the code from Python 2 to Python 3, and there could be other issues somewhere, I don't know. I would say you would have to know something about Python to be able to do that.

I got a lot of help from @jneilliii on Discord. I was able to fix all the errors. It works now.
The problem was indeed the transition from Python2 to Python3.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.