Plugins not showing up on ethernet


#1

What is the problem?
Plugins installed when accessing Octoprint through the IP address the RPi is on from Wifi, are not showing as installed when accessing Octoprint through the wired IP address. So if i log into Octoprint from the WIFI ip address all my plugin are there. If i access through the wired ethernet, my plugins aren't installed.

What did you already try to solve it?
I logged out and back into Octoprint. Cannot reboot until current print is complete

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)
Octoprint version-1.38
Octopi version -0.15.0


#2

Did you try forcing a full asset reload in the browser (depending on browser/OS: CMD-SHIFT-R or CTRL-SHIFT-R)? Are you sure it's the same OctoPrint instance? Did you reboot after installing the plugins to begin with?


#3

I know it was the correct instance of octoprint since I had a print running and was able to see the print on the camera, under the controls tab. The other printers were not running.

I found it odd that I could go from one to the other, see the same video, but one had the plugins and one did not.

I will end up doing a reboot of the computer and the RPI and try again. I may just turn off wifi and run only on Ethernet, since I get better streaming when wired.


#4

As a former I.T. guy, I'd have to wonder if your Internet router treats the wired versus wi-fi networks differently. It's entirely possible that the router has looser rules on the wi-fi side of things, for some strange reason.

(At the code academy where I work, some guy who doesn't have an I.T. background has programmed the local router and it's a mess.)


There is a strange feature/bug aspect of browser local storage which can manifest itself in the way you are describing.

Local storage (a place where a programmer can store a JSON object/database-like thing) is stored using three pieces of information: protocol + app/website + the IP address which was used to reach it.

Scenario:

  1. Under the control of your wi-fi session's IP address, something saves information in local storage
  2. You turn off wi-fi, plug in an RJ-45 Ethernet cable and refresh your browser to find that it now no longer has access to that earlier local storage

#5

Rebooting the PC didn’t help.

I tried from my tablet and it was good. So it’s a computer issue not an Octoprint issue.

I’ll figure it out and fix it, now that it’s the computer and not Octoprint or router.


#6

Clear your cache? Probably a caching issue.