POE Hat and Pi Camera

I recently added the POE hat to my Pi 3b+ and since then the camera (pi camera v2) no longer works.

If I disconnect the POE Ethernet plug the camera starts to work again. The POE switch has nothing else on it at the moment and is ad-link 48v 8 port switch.

Has anyone else had this issue?

I have attached the only 2 logs generated.

Thank You
Dannyoctologs.zip (10.8 KB)

I'm not sure if it helps but there is a rpi-poe device-tree. Afaik it's for controlling the fan on the hat but maybe it helps with this issue.

add dtoverlay=rpi-poe to your config.txt in the boot partition.

Also I would try to fully power off the pi, disconnect all usb devices and try again.

Strange, I have PoE hats on a number of my Pi's (Kodi and OctoPrint) one of which (OctoPrint) has a Raspberry Pi Camera (V2), it works flawlessly. Only thing that appears to be different is I'm using a Netgear FS726TP SmartSwitch with PoE.

According to the switch status the port is delivering 55.5V at 68mA (3.7W). This goes up to 106mA if I use a USB port on the Pi to power an SKR V1.3 with a TFT35-E3 touch screen.

Maybe it's an issue with your switch? Might be worth (a) checking the cable and (b) trying a PoE Midspan Injector.

The only relevant tweak I have in my config.txt is

# Tweak the fan parameters - see: https://github.com/raspberrypi/firmware ... ADME#L1804


Which raises the temperature at which the fan runs slightly (stops it being annoying when the pi is mounted on the back of a telly!)

Andy B.

Thanks for the suggestions,added the dtoverlay to no avail - same results and nothing plugged into USB. I also confirmed that I have the 3rd gen POE hat so the power draw issues should not be a concern. I also tried a different TP-Link poe switch to no avail. I also tried a couple of mfg'd as well as home made Ethernet cables.

I don't have a managed switch or a 48v injector so I cant see how much power is being consumed, but the Pi is the only thing connected while I test.

That being said - found the issue...I had increased the video to be 720 30fps.....I lowered this back to the default of 640 and 10fps and it works.....I guess I just need to play around and find the threshold.....

Thanks for the help everyone.

As an amendment I tested the following:

1280p 30fps, 20fp and 10fps - all failed.
720p 30fps, 20fps and 10fps - which is the only one that worked.

Not sure how to compensate for that - a job for another.

Thanks again

Danny B

Sorry didn't think to post the content of octopi.txt, for what it's worth I'm using:

camera_raspi_options="-x 1280 -y 720 -fps 20"

If memory serves me correctly the Pi Camera/OctoPrint doesn't like higher resolutions

I had mine set to:

camera_raspi_options="-x 1280 -y 720 -fps 30"

but even testing 20fps it still failed.

I have to wonder if it would perform any better on a pi4 vs the 3b+ that I am using.

Curious, I'm using my settings on a 3B+ with a Genuine RasPi PoE Hat without issue, are you running anything else that would load the pi like the desktop?

Nope, this is only used for octoprint running headless and nothing other then the printer and piv2 camera plugged in (although the issue was present even when it was not).

That being said I checked and the snapshots/videos are still being generated at the higher resolution, it just crashed the web interface.

In which case I haven't a clue... sorry!

I found the issue....my ribbon cable was a little beat up so I got a new one, and voila - it now works without issue...

1 Like