Power on sleep not connecting

What is the problem?

I use a remote power switch to turn everything of and on including Octoprint and my printer. When ever my PI powers up it boots to the OctDash, bi
It goes to sleep rather than connecting, so I have to physically go down and touch the screen to get it to connect.

What did you already try to solve it?

Research why starts in sleep

Have you tried running in safe mode?

Not sure how that would help

Did running in safe mode solve the problem?

Not sure that would help

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

1.7, Pi 4 B+ with a touch screen

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

WRITE HERE

Hello @Hpolack !

That would help... :wink:

However: Try the safe mode.

Would it make a difference, if in OctoPrint you select the checkbox 'Auto connect on server startup'?

I believe recent versions of OctoDash don't try and trigger the connection automatically themselves, only when the screen is pressed. So if OctoPrint connects automatically then OctoDash will know this and change the display accordingly.

Also, side not - make sure you are not just killing the power to the Pi, it can quite easily cause the SD card to become corrupted. Make sure it shuts down fully first.

Thanks, I will take a look for that setting and yes I was just killing the power despite the many reference I see to the contrary. I guess I don't want to have to leave it on all the time if I am not printing and I don't want to have to manually turn it off physically or through remote. I was just hoping to hit the power off switch on my Wyze plug :slight_smile: I guess I will reconsider that action.

I have a smart plug on my printer and an OctoPrint plugin so I can turn it on and off from any computer in my LAN. My Raspberry Pi is left running all the time as the power consumed is very minimal. If I need to turn it off, there's an option on the OctoPrint web page to shutdown the system first.