Print layer problems with Ocotoprint on Raspberry Pi Zero v1.3 + Prusa MK3 Octoprint 1.5.3

What is the problem?

Hello to all,
I installed a Raspi Zero W on my Prusa i3 MK3.
This Raspi is not recommended because of its power. But it is very easy to install. There is no welding and no modification of the printer box. I was looking for a practical solution to upload my GCODE files to the Prusa. Without using the SD card all the time.

The installation worked as expected in the Prusa tutorial. You can find this tutorial here: Prusa Knowledge Base

I'm writing on this forum because I have a printing layer problem. I can't figure out where it comes from. And while searching on the forum I didn't find a similar problem.

I printed one of my files via octoprint. It is a pencil pot.
I uploaded the file -> to the Raspi memory. And maybe that's the cause... But let's wait before conclusions.

When I print my GCODE file from the SD card in my printer, and I launch this file directly from the printer: the 3D part is just perfect.

But when I upload the GCODE via Octoprint in the memory of my Raspi and then print it : that's when things get out of control.

The first layers are well printed. Then a problem between layers appears. It's a kind of vibration in the machine.
I don't know if it's really that: it's a bit as if the Z-axis was taking some play with each layer. After 5 cm of height, the first impacts are visible. After 10 cm the piece has a really unpleasant texture.

Has anyone ever had this before?
Thanks for your Help

The Quarkos

What did you already try to solve it?

  • I tried to slice the STL file to create a new GCODE.
  • I have recalibrated the Z-axis
  • I changed the printing speed
  • I printed the GCODE directly from the printer without using Octoprint.

Have you tried running in safe mode?

No

Did running in safe mode solve the problem?

NC

Complete Logs

octoprint.log (158.2 KB)

Additional information about your setup

OctoPrint version 1.5.3
OctoPi version : 0.15.0PE
Printer : Prusa i3 MK3
Firmware : 3.9.3
Browser : Chome
OS : Mac OS 11.1

Thanks for your help !

That stuttering is exactly the reason why you shouldn't use a Pi Zero :smiley:

1 Like

Thanks for your quick reply @PrintedWeezl !
Do you think is exaclty the reason ?

If looks like this - yes :slight_smile:


I really wish Prusa would take this bloody tutorial down. It goes completely against my recommendations (and I wrote OctoPrint ffs), but all my pleas just go ignored 🤷

1 Like

Thanks a lot for your help @foosel ! I will also send a mail to Prusa.
It's just a bad idea to continue to share this idea if the program does not work properly under these conditions